Newbie: can't get radio to work (TBS Crossfire to Matek F765-WING)

Hi everyone. I’ve been running Crossfire on my Betaflight quads for a long time and I am familiar with the system. I am new to Ardupilot though. I have a Matek F765-WING which I have flashed with Arduplane 4.1.0 because of Crossfire connectivity - hoping I am right so far. I am not interested in RC over Mavlink.

On the Crossfire Tx (running 4.11) I have set Channel 8 to CRSF TX and Channel 7 to CRSF Rx.
Wired signal pin of channel 8 to RX3 on the Matek
Wired signal pin of channel 7 to TX3 on the Matek
In Misson Planner the only thing I have changed is to set SERIAL3_PROTOCOL to 23 (RCIN)

I have no reaction to stick movements in both Setup->Radio Calibration and Setup->Servo Output

What am I missing?

Many thanks for your support in advance!

I can’t explain why, but ArduPilot Serial port mapping doesn’t line up with the UART labels. I’m sure there’s a good reason, but it’s beyond me.

On the F765 TX/RX3 is SERIAL4.

You don’t need MAVLink but if you’re interested in setting up the Yaapu telemetry through CRSF here’s a good thread on it.

Hi, did you check the wiki, serial ordering is detailed there

@Allister @yaapu Gentlemen, many thanks for your help, very much appreciated! I really didn’t expect the UART numbering not to match the numbering in MP. All good now, up and running. Telemetry also works fine, next thing I’ll need to do is implement the “yapuu telemetry” screen on my Radiomaster and setup my plane. Can’t wait to fly my first Ardupilot aircraft!

Sorry this is quite old. @ardudmy how did you get telemetry through CRSF?

I am running Matek f405-wing and crsf using crossfire tx and nano rx. I also have tbs unify Evo vtx. Rc inputs are working fine using ch1 and ch2 on Rx going to serial 1 on f405. Ch3 and ch4 are controlling the vtx no problems also using crsf.

When I go to discover sensors on my taranis qX7 nothing is discovered. It just keeps searching.

Did you have to set anything else?