Newbie, Arming Issue

Hi, this is my first APM quad copter.

I followed the wizard and wiki docs to complete all setup/calibration of the quad copter. This includes calibrating the radio, compass and accelerometer. I also did the motor setup to get the throttle ranges and number of cells i have in my battery.

The only problem is that I didnt buy a GPS, I was originally planning to first get the quad setup and then test it without GPS first. Then add the GPS later. However, whenever I try to arm the motors, it would fail. When I checked the HUD on Mission Planner, all it says is DISARMED, GPS: NO GPS (in lower right).

I have disabled GPS heading as well as geofencing. I have even tried disabling prearm checks altogether via the Arming Check (under standard params) and verified in the full parameter list that the value is set to zero.

I still am unable to arm the quadcopter. My qtn is, does APM “REQUIRE” a GPS to operate? And if it doesn’t how can I arm and fly the quadcopter? I tried searching on google and looking through various resources but to no avail…

Any help would be greatly appreciated.


Did you select “Skip GPS” for the pre-arm check in Standard Params, and then “Write Params”?

This will set the “ARMING_CHECK” paramenter, AHRS_USE_GPS has a different meaning (see

Best Regards,

Hi Claus

I have tried setting Arming Check to “Skip GPS” then “Write Params”. I have also tried setting Arming Check to “Disabled”, then “Write Params”.

In both cases, I could not arm the controller. After hold the stick right for 5 seconds, the red led double flashes and motors do not work.

Hmm, the weirdest thing just happened, I was recording a video to demonstrate the problem I was having, and when I got to the arming part, it worked… wow, unexpected, but nonetheless a welcoming sign. Thanks for your help though, at least now I can continue the setup without waiting for GPS :slight_smile: