New to Pixhawk, motor will not run

Thanks in advance for any Help, I received a lot of help from forum members when setting up my APM 2.6 Heli, now I am trying with a Pixhawk heli.
Pixhawk, 450 Hobbyking heli, Tarot FBL head, Emax digital servos, Flysky TH-9X radio and receiver (all this equipment was working well with APM)
I have install Chris Olson ArduHeli 3.5.4 V3 firmware, I am using PPM encoder, I have wired PPM encoder and Flysky receiver in cross channel Futaba pattern (worked well with APM) ESC is on channel 8, all channels seem to be working correct.
Problem is motor will not run?
In Mission Planner failsafe screen i can arm Pixhawk and I can see the channel 8 output bar increasing if ESC 3 wire is not plugged into channel 8 outpuit, but as soon as I plug in ESC to ch 8 output bar does not move? When plugged into ch 8 ESC is always beeping? I have tried different ESC and motors no change?
I have attached parameter file, Thanks for any help
Pixhawk 5-21-18.param (13.5 KB)

William, there should be no need to cross-wire your FlySky radio/PPM encoder. I assume you are using airplane mode in the radio? You just need to set up a switch and knob on Channel 8 - the knob to adjust the speed you want, the switch turns it on or off.

If your ESC has no governor in it you could use ArduHeli 3.5.6, which has the new throttle curve in it (otherwise Copter 3.6-rc1 has it). And use H_RSC_MODE 3.

H_RSC_MODE 1 throttle (which you are using) is designed for governors that have adjustable speeds. Your ESC beeping indicates it is getting a throttle signal above it’s arming point, and with MODE 1 that signal is coming from your radio. With MODE 3 in ArduHeli 3.5.6 all you need is a switch to turn channel 8 on or off and the throttle curve is handled in the software with the H_RSC_THRCRV settings.

Chris, thanks again you have always been a great help
With my Flysky TH9X I have to run Helicopter, heli 1 mode with APM 3.2.1 and the cross-wire receiver to APM setup, otherwise the collective and throttle never worked together, airplane mode never worked for me?
Correct ESC has no governor, but I have always used H_RSC_MODE 1 with my APM heli, working well after all your help?
I will try lowering throttle signal in radio (maybe under end points).
If no luck I will try your other suggestions?
APM was just getting to the point I was understanding a good share of the setup, now with Pixhawk it is a new ball game.

Hi William, If possible I would recommend using an SBus receiver and just connecting the sbus out from the receiver to the RCIN of the pixhawk. It is way simpler and is one less thing that could fail and cause your heli to crash. I used the PPM encoders in the past. I wasn’t too sure if I was seeing delays due to the encoder. then I realized I could buy an SBUS receiver that is much cheaper than an 8 channel receiver (at least it was for Futaba receivers).

The point is, with the new firmware with the five-point throttle curve you won’t need the collective and throttle to work together. In the newer firmware Mode 1 is designed for governors with adjustable speed. With the newer firmware (ArduHeli 3.5.6 or Copter 3.6-rc1) you can use Mode 3, hook everything straight, use no mixes in the radio, use your collective as normal, assign a on-off switch to channel 8 for throttle and let the Pixhawk handle the throttle curve. It works very nice compared to the old firmware you were using.

Also, as Bill noted those PWM encoders can be sometimes wonky. Make sure the values look good on your RC outputs in your ground station. Pixahawk can use either S.Bus or PPM SUM. I don’t think S.Bus is available for your radio system, but you can get receivers for it that have PPM SUM output (will have 8 channels only).

Thanks Chris, Bill
To my knowledge I do not know of a TH-9X Flysky sbus or ppm output reciever without changing module to Frisky, if you know of one let me know?
Chris I will try your setup suggestions as soon as time allows, retired but seem to have less time now, too many hobbies, friends.
Thanks again

I thought that radio might be compatible with the some of the “B” series receivers with PPM SUM? It may not, though. As long as you’re getting clean output from your PPM encoder it should work. But the cross wiring is definitely not required with the Pixhawk and the newer firmware. We have better ways to handle that now that you have upgraded :grinning:

I am updating to Arduheli 3.5.6 on my Pixhawk.
There is a note on your download page that says
Note 2: When upgrading to ArduHeli 3.5.6, if you were using the MODE 3 throttle control with three-point curve you MUST set the parameters for the new five-point curve in 3.5.6.
Please Explain

William, this would only apply if you had a working three-point throttle curve in an earlier version of the firmware and upgraded to 3.5.6. Since you had never used Mode 3 throttle before it will not affect your setup. However you must still set the points for the throttle curve. The defaults are for a gas piston engine.

Sorry I know I must be doing something wrong still not able to run motor?
I have loaded Arduheli 3.5.6 wired ppm encoder channels straight across to receiver inputs. I have tried using airplane mode on Flysky 9X, Pixhawk will not arm, and also in Airplane mode and I have the same problem also in airplane mode I have no throttle curve in radio?
Loaded Arduheli 3.5.6 again I switched back to Helicopter mode Heli 1 wired straight across ppm to receiver, seems collective is working
correctly, using H_RSC_MODE 3, I am using Throttle Hold switch to enable and disable throttle, (seems to be working because collective will not move when switch is enabled)) but I cannot get motor to run?
Does on/off switch have to be assigned to channel 8 since this is the channel the ESC is getting signal from (i have tried channel 7 or 8 same problem enabled or disabled = no arm?
Again getting pre arm check Motor Interlock enabled error, ESC is beeping?
Almost ready to go back to APM?
Thanks again

William, I would recommend going back to the airplane model in your transmitter. The issue you were having with the Motor interlock enable occurs when your TX channel 8 position is above the RC8_MIN pwm position by more than 10 PWM. So initially when you power the pixhawk you want your TX channel 8 output to be at the MIN value for channel 8. Then once you use a switch to increase the value of your channel 8 in your transmitter, the motor should start.
I hope this helps. Let me know how it goes

I am having same trouble of not getting motor start, even motor is armed as shown in MP, and PWM value of “CH8 out” increases as I increase the knob (CH8) after armed.
My setup is Align 450 flybar, Pixhack, arducopter 3.5.5, MP 1.3.56, Spektrum DX7s, Redcon 7 CH Rx, and PPM encoder. I have been successful flying another heli which is Align 450 FBL, APM2.6, arducopter 3.2.1, MP1.3.56, Spektrum DX7s and Orange 10-CH Rx.
Recently after I set up this 450 flybar with Pixhack, I can arm the motor and the motor DID START without problem. Without changing anything, upon powering up one day during bench testing , after arming, motor would not start. Message ”Motor interlock enable” pop up from time to time, but not every time when powering up.
I tried to disable the safety switch by setting BRD_SAFETYSWITCH to 0, but it did not help. (This works in my quad with PIxhawk ………… when after pressing the ARM switch, I can’t get it armed. After disabling the safety switch, I can arm right away). I also used another Rx (by passing the Pixhack and the Redcon Rx) to test the ESC and motor. These both work without problem.
Any help is appreciated.

Try in your DX7 to check if your throttle travel is low enough.
In my DX8 I went to Servo than Throttle and lower more than 100%. Try 1o2% ore more. That was most of the time my problem for not getting the Pixhawk to arm. I am not using the DX8 anymore only for flight simulator.
OpenTX in my FrSky TX,es is a much better software. I am not going back to Spektrum.
If it is not a arming Problem with the TX I cannot help you further.

I would like to know if you solved this problem?
I have same problem with 90% same setup except I am using a Flysky Th-9X transmitter and 9ch receiver with PPM encoder.
I am using this same setup (without PPM encoder) with a another 450 heli and APM 2.6, ver 3.2.1 and all is working well?
I also can see CH8 out increasing but no motor running ( I am using Throttle Hold as a safety switch on CH8 ) makes no difference switch on or off?
I have tried solutions from this forum (very helpful) and from the internet with no good results?
Thanks in advance

I think I know the problem. So did my previous email help you get rid of the motor interlock issue?

If it did and you can arm but the ESC is not responding to the RC8_out then I think the servo out min and max are not set correctly. Set Servo8_Min to 1000 and Servo8_Max to 2000. I believe the ESC needs to see a PWM below a certain value in order for it to initialize

Let me know how that works.

Thanks for yr reply. I did lower the throttle so I managed to arm, and get the motor running. But all of a sudden, even I can arm, but motor does not run.

Assuming you have heli_RSC assigned to channel 8, what is are the values for Servo8_Max and Servo8_Min?

Hi Bill,

RSC is assigned to Ch 8.
Servo8 _Max and Min are 1900 and 1100 pwm respectively.

FYI, RC8_Max is 1939 and RC8_Min is 1025.
But RC8_Trim is 1025. Is it normal ?

Appreciate your help.

I think your problem is when you switched to AC 3.5.5, the RC inputs were separated from the Servo outputs. In AC3.2.1 they used the same min and max for the RC8 channel. When you switched to AC 3.5.5 the servo output min and max were defaulted to 1100 and 1900. So my suggestion is to go into full parameter list in Mission planner Config/Tuning tab and modify the Servo8_min and Servo8_max to be the same as your RC8_min and RC8_max. My theory is that your ESC is not seeing a low enough PWM in order for it to initialize.
What RSC mode are you using? If you are using Mode 3 then you may want to make Servo8 min and max 1000 and 2000 respectively to make it easier to translate between the throttle curve value and the PWM. If you are using Mode 1 then you’ll want to stick to what I described above (min and max the same as RC8 min and max).

Hi Bill,

I did what you suggested… change Servo8_min and max to same as
RC8_min and max (at 1025 and 1939), but motor still not spool up, even
though MP still shows “ARMED”. I am using Mode 1.

If all the relevant PWM values are not OK, the motor would not arm. So I
suspect the ESC is faulty*, which proves to be false after isolating the
ESC for testing.*

In fact, the motor did run at one stage, and after that, I did not change
any setting in CONFIG before it did not work.

Thank you for your continued interest to help.

Any clue, pls let me know.