New project, particular boat configuration and associated troubles

Hello there,

So I am new on the forum, I will try to respect the use, please excuse me if I do not.

I started a project of self-controled boat a few weeks ago and the fact is I have what I call a stupid problem I cannot solve. That is why I ask for your help.

Here are the data of my work :

  • 2 brushless motors boat
  • Radiolink equipment = Pixhawk and T8FB radio
  • telemetry 433Mhz linked to my computer
  • Mission Planner as ground station

I read a lot and check videos too on the Pixhawk. I think I know what I need to know and the first settings / configuration and cabling.

I set the Pixhawk, ARDUROVER mode, I did the calibrations of the compass, the radio, all is OK.
The first work was done directly plugged to the computer with the USB cable.
The radio receiver is put in S-Bus mode, channels are :
1 = AIL
2 = ELE
3 = THR
4 = RUD

1 and 2 are the right stick.
3 and 4 the left one.
In the standard use of the boat, right motor is on channel 2 and left motor on channel 3.

Then I set the servo outputs :
1 = disable
2 = right motor
3 = left motor
4 = disable
5 = RCIN 5
6 = disable
7 = disable
8 = RCIN 8

I plugged the whole components together with a DC lab power supply 12V.
First ESC is put in n.2 Main out, Second ESC in n.3 out.
I also put a small servo in n.5 out and a RC swith in n.8 out.

Then I put the telemetry to control the Pix from the boat on my computer and Mission planner.

Here is the issue.

I start the Pix, all is OK. I launch MP on the computer and connect the PIX. Still OK.

I arm the Pix, still ok. The ESC’s start, beeping is correct. I perform motor test, still OK.

Motor testing is still OK. But, I have no control on the motors with the radio. What is wrong?
On all videos I saw, it is possible to control the RC boat / plane / quadri with the radio before making a plan.

I have perform a lot of tests. The only thing I see important, if I put RCIN 2 and RCIN 3 in place of left or right motor in the servo output settings, I can control the motors with the radio but motor test in MP fails.

Then I have other question. The servo and RC swith does not work too. I read in the PIX doc I should put an UBEC 5V power in the AUX OUT so that current will make servo and other components work. But in a video I saw there was told not to put 2 power entries inside the PIX (power module + BEC or UBEC).
What about this fact? How can I make my components work?

If I put component directly on channel 5 and 8 of my receiver it makes the PIX disarmed…

I searched solutions on the Internet, but nothing is clear, I think it is time for me to talk about with some people to have advices.

Thank you in advance for your help!

Are you sure that rc controller is bind with receiver?
Are you sure that you press the safety switch?

After arming and pressing the safety switch the servo out puts should be there.

I assume you have did the radio and other mandatory calibrations.

To my very little knowledge 1 bec can supply 2 servos. In the wiki it’s shown that for rover you must connect them to aux 5 or 6 as servo rail (gnd and 5V only). And normal ESC’s pwm inputs shall not carry 5V to pixhawk (only gnd and signal).

It looks like a wrong sbus/ppm/pwm configuration or a fail safe is active

And are you sure about the max amperage of the lab 12V supply is enough for your esc’s and motors?


Thank you for your answer. I am sorry to not be back before, I finally found the problem, it was a bad firmware loading in the Pix.

So now all is working in manual mode, I have all controls as I wanted.

I put PILOT_STEER_TYPE = 1 in order to separate right and left motors (no mix)
I also change RC MAP so that right stick correponds to right motor and left stick to left motor.

My new problems are the speed / steer settings before use auto-mode as I want to to.
I follow all advices of the website, Youtube videos of M. Mackay ( and others…) but something does not work.

If I put accro mode in place of manual, the boat turns on it self, no PID setting can change this. In the graph I clearly see achieved never meets desired PID.

I think my particular radio / motor configuration is the problem but I do not know what to chang to solve the problem.

I am searching on the internet but I do not find anything convincing.
My intuition makes me think the RC MAP change is not good but a change is another problem with bad stick controle (right for left motor…)

Please post a .bin log.

Here it is.

I upload two, one of yesterday with my old config (described in the first post) and one this morning with a new config done yesterday evening.

The new config is :

  • throttle left on pin 1
  • throttle right on pin 3
  • pin1 linked to my left joystick with RCMAP
  • pin 3 is right stick with RCMAP
  • still steer type = 1

Late yesterday I tried something just to see. I planned a mission in the garden and I moved the boat by my hands. Result was not so bad, motors moved in a way to make the boat going to the right waypoints… I am pretty sure that on water settings will do the boat not moving so good (zig-zag or other) but the result was quite correct meaning the boat can reached a waypoint.

But, if I deal with the speed settings like the video, graph is still not good.

Thanks for your help.

Old configuration :!vCBgnIyB!WDqeG_xhUdGuq0JT54DwgITNDgohF8SCZslURsSmDsI

New :!2WYGGaSJ!DmpBUy7caeZDiAbviFflG1Q602ZCGAZJ0z0fWXHMaXs

Here is a new log of a test in real condition I did on 6/06.!PXA22AiQ!eBmDOZBsVtYKKaf5MGbhIQVHmmcZsd3o-zyjYBFzgbI

The test was not good, as we could imagine…

Fact is the result is not so worst,meaning the boat did not go at full speed in the opposite direction.

No, the boat was very slow, searching for right direction, then took a quite right direction to the waypoint. Not perfect, but correct.
PID settings are so small (0.2 / 0.4) I think this is one of the reason of the small speed.
But I have no mean to know what value change / put as the graph in the flight data do not show me what I expect (like the video of M. Mackay etc.)

I do not know what I must check in the log. I try to find an error or something like this but I did not find anything.

Thanks in advance for your help!

Increase your ATC_STR_FF to 1. Program an auto mission around a square of waypoints and adjust things to see what happens. I don’t know what size boat this is but mine has ATC_STR_P and I at .4 and the FF at 1 or 1.5. NAVL1 is around 14 I think.

The boat is 70x25cm and about 5 kg. Very reactive boat, it can goes fast and turn on itself really fast too.

I will try these settings today and let you know what about.

Hi there!

Sorry to not give any feedback sooner, a lot to do again.

So thank you David, it worked! ; )
Accuracy must be improoved but the idea is there, the boat can follow a defined way and stops on waypoints.

I will work on the different values to improove the accuracy of the boat but first result is really good.

Then I have a a new need for my electronic system.
As I am not the only user of the boat and other people are not used to RC technology, I want to add a sort of backup system on the boat in order to shortcut the Pix.

Summary of my idea :

  • 2 receivers are put in the boat : 1 is ppm and work with the Pix. 1 is pwm and works directly with the radio
  • 2 UBEC alimentations are plugged on a selector switch, 1 is linked to the Pix, 1 is linked to the pwm receiver
  • with the selector switch, we can choose to lead the Pix UBEC or the receiver UBEC
  • ESC are plugged with a Y cable to the Pix and the pwm reveiver
  • all “+” cables (BEC) are cut

The schematic is under the message.

I have done this cabling. It does not work…

The problem is, if the pwm Rx is plugged to ESC, the Pix does not control the ESC’s. There is always the “bip” meaning ESC’s are not loaded and ready to run.
If I unplug the ESC’s from the pwm Rx, it is OK, Pix is running ESC.

If all is plugged and pwm Rx is selected, the boat works fine. (Pix is off)

I can understand this cabling is a little bit strange, but I do not understand why Pix cannot work corretly if ESC are plugged in an other Rx. And the Rx is off, the is no current inside. The working LED is off.

If anyone have any idea, I take it!