New problem after crash: substantial wobble, can't fly

I’m looking for help diagnosing a problem that appeared after a crash. The quad was flying just fine before the crash (user error). In the crash I broke an arm of my 450 quad in X configuration. This ripped an ESC wire out of the bullet connector. After repairing that, I tried to fly and the quad starts to wobble as it lifts of the ground then the wobble increases rapidly after liftoff and it immediately crashes if I don’t land it. I replaced the ESC that had the damage but the problem persisted. I reset my APM 2.6, went through the full setup wizard in Mission Planner, configured all the ESCs (just to make sure I had them right) and the problem was still there. I can’t get into a hover but the vibrations look good to me unless I’m not reading them correctly. What I’m seeing in the logs is significant deviation of RollIn and Roll, and PitchIn and Pitch. The blades look good but I tried a different set and still see the problem. Next I plan on replacing all the ESCs then all the motors to see if that solves anything but I wanted to seek input before I do this. Is there something else I’m missing? Log attached.


Update: I replaced all the motors and have the same symptoms. I hope to replace all the ESCs and will report back. Hopefully that resolves this but if not, I’ll be stumped. If it does, is there a good way to test ESCs (aside from process of elimination)?

Something is screwed up. Have you checked your motor order carefully?

I’m pretty sure I checked motor order multiple times, but I’ll check again. And if that doesn’t work, I’ll replace all the ESCs. I’m on the road now so it will be a couple of days before I get to it and can report back.

Wow, I can’t believe it has been so long since my last flight, but today was my first successful flight after the crash mentioned above. Between buying a house and the ensuing projects I haven’t had time to look at this until now. I don’t know exactly what the original problem was, but without any mechanical/physical changes to my UAV, the problem is gone after:

  1. upgrading to 3.1.5
  2. reset to factory settings
  3. standard setup wizard

I just wanted to report back in case anyone else has a similar problem.