New Mavlink Log Download Error

Hey guys, before was always receiving “Cannot get log list”, however now I get “Error Receiving Log List” whenever I try to download via Mavlink in MP.

Please let me know any additional information you may require to look into this.

Have tried it on 3 different computers with different USB cables many times.

Please find a screen captures both the error and the settings menu attached.

LOG_BITMASK is set to NearlyAll.

It’s not a major, but any insight into a way to get it going would be appreciated. I’m not entirely sure but I don’t think it ever worked with this particular Pixhawk (my 2nd).

Thanks heaps in advance. Loving 3.2, great work and thanks to all the devs making APM an awesome platform.

Happy New Years!

One thing that changed with 3.2 firmware was the elimination of CLI for all boards other than Pixhawk. In order to download logs on older boards you must download logs via Mavlink.

Instuctions to do this are located here

Warning #2 on the Arducopter 3.2 Beta Testing Blog Post

I get this message too. Have followed the instructions as suggested above. But that’s when I get the message ‘error receiving log list’. Clicking the ‘Download DataFlash Log Via Mavlink’ button on the flight data screen.

Are you using genuine 3DR Flight Controllers or are they clones?
If they are clones, that may be your problem.

I am running a genuine PixHawk Controller from 3DR and I get the same error when I try to download the log list.