New installation with continuous yaw rotating on take off

Hello all,

After looking some threats in the forum I’m unable to solve an issue with a micro quad.

It is a LR4 frame with Matek H743 mini FC, T-Motor 4 in 1 ESC, 1404 motors and M8Q-5883 Matek GPS-compass. Flying fine previously with INav firmware. Compass is not working fine in INav nor Ardupilot. Tried with compass deactivated.

The problem arises on arming. On throttle up the quad rotates fast on himself (yaw) sometimes CW, CCW others, so take off is not possible.

The rotating sense is reversed in this configuration. Motor testing has gone ok (ordering and rotating direction). Propellers are correctly set, servo outputs had been tried with and without being reversed.

Any idea?


1 Like

Definitely sounds like an ordering or rotating problem - I covered this in my build blog, worth checking since the Matek mini is essentially the same as the board I am using - ArduCopter 7" LR Build Video 14 - Initial Configuration, Ready to Arm - YouTube

Thanks Andy.

At the end, as easy as searching the forum with better questions.

Reversed propellers confuses the FC even with correct motor rotation and propellers. Changing frame type to Quad H solves the situation.