New flight mode not visible on terminal and GCS

Hi all,
I’m trying to develop a new flight mode based on alt_hold. I have followed the same procedure as in the official website. All is working as required except that I’m not able to see the name of mode. I could only call as mode #(Mode 29 in my case).
Git page: GitHub - sarath-asoka/ardupilot: ArduPlane, ArduCopter, ArduRover, ArduSub source
Can somebody help me on this ?

Hi @sasoka,

This is expected behaviour. I think that most ground stations get their list of modes from the ardupilot repo’s parameter description (e.g. FLTMODE1’s parameter docs) so they won’t know about the new mode you’re adding. If your mode is eventually added to the main ardupilot repo then it will appear.

If you’re using Mission Planner then somewhere in one of the “MissionPlanner” directories on your PC there might be an xml file that holds the list of modes.

For MAVProxy to see the list you’d probably need to modify something in pymavlink but I’m not totally sure.

1 Like

Hi @rmackay9 ,

Thank you for the information.
Regarding mission planner, I found a .xml file called ParameterMetaDataBackup.xml. In this file, I found flight modes, to which i added my custom mode name.

For mavproxy, I added my custom flight mode name into ardupilotmega.xml.

Still the issue persists.

Hi @sasoka,
Could you solve this problem? because I`m also facing this issue.