New fixed wing PID system and autotune

the new PID values will be automatically upgraded to equivalent values when you go from 4.0 to 4.1

no, it is probably that you have the AUTOTUNE_LEVEL set too low for the responsiveness you want. If you post a log we can take a look

tridge,can you tell if the unhealth AHRS is bug or some wrong in firmware 4.1,i can arm the plane but it always show unhealth AHRS,I’m not sure if my FC have a problem.the gps is ok .

I guess the problem is in EKF3,but i don’t know much about EKF

I can’t tell what is happening without logs. Both tlog and bin log from sdcard if possible

OK,thanks I will sent the log later

Have you tested the new released stable 4.1 version on matek f405.
I have two f405 and they behave very strange for me. The pitch an roll moves extemly lot even at small motions,it gives full movement to the elevator and ailerons…and it does not react fo PID changes

i autotune 2 planes with 4.1 stable
binary1200 and atomrc dolphin without issues


Thanks…meanwhile i could also tune the plane…set PID to low and made an autotune.
Now everything is perfect. It seems its only twitchy in the hand but smoothe in the air😉

1 Like

@tridge current Autotune give bad results if plane tuned in calm day.
Here graph from atomrc dolphin:

params show previous values, tuned in calm day. And log show params tuned in windy conditions (about 30-40km\h wind). Autotune perfomed about 50% throttle.
As we can see D lowered about twice.
and here oscillation at start

also i think D bad for planes…
here video takeoff in windy day after autotuning in calm day

I found that turning down RLL_RATE_SMAX (or pitch) cleared up the oscillations for me.

yes, the SMAX is what determines the maximum actuation rate. The default of 150 is good for most aircraft, but some will need a lower value.
@Alexey_Degterev also note that oscillations at the start of the autotune process is expected, and oscillations on takeoff can happen due to poor wind estimation. In both cases a lower SMAX will usually take care of it. Please try with a SMAX of 100 or 75 and see if that produces a better tune for you.
If it doesn’t then please post a link to a log so I can look at it more carefully

The new Autotune is not working well with my ASW28. Tried several times and ends up oscilating a lot. I think it brings too much D term. I manually tried to lower them but there is something else that I cannot figure out. Today give another try and repeat the autotune, in FBWA the plane can be handle well but when I switch to Stabilize there are moments that I turn right and it simply doesnt turn, its really scary. I have an EXTRA300 and after the autotunning it was oscilating during the takeoff. With an Easystar it finishes with too much D term and not able to fly and end up the tunning manually. Could someone check on todays ASW28 log please. Thank You!
Log File

If you’re getting D term oscillations you can lower PTCH_RATE_SMAX (or RLL) and that should eliminate that.

Thank you, I will give a try!

This was before adjusting the SMAX ASW28 Bad Tunning - YouTube
It started to bounce almost desintegrating in the air :slight_smile:

Yikes, that’s not good. Have you tried adjusting the SMAX yet?

Not yet, will do when the weather becomes better, its raining :frowning: !
I think tunning is not working well because this glider has a small issue due to the airspeed location. I install it on the left wing and I think its influencing the air dynamics. I noticed when diving it slightly turns to the left, also the auto trim is adjusting the right wing ailerons, to make it go right. So, there is a mechanic issue that can be solved if I install it in the center, maybe the tail stabilizer. With this I2C bus airspeed I dont think it will work if you are far away form the controller, the solution must be with CAN bus which is more expensive. Anyway with the same conditions the old auto tunning was ok. ASAP will adjust the SMAX. Thanks!

1 Like

I have an interesting idea and am curious on the thought of others. I have a plane that fly’s stable with px4 but want to use arduplane instead. Has any one tried taking the gain settings from there px4 and put them into the ardupilot firmware. It looks like with the new updated pid system in ardupilot they are apples to apples by comparison.

thanks! Lowered both SMAX to 100, and here difference. I think for ROLL need SMAX lower more


I’m just setting up a tiny HeeWing Ranger T1 with Arduplane 4.1.7. After initial autotune, rll_rate_fltt and pitch_rate_fltt were down around 2 or 3. I was just looking through the autotune instructions, and for light, agile aircraft they recommend values of 20. Am I reading that right? That’s almost an order of magnitude change.