Servers by jDrones

New Fence "Menu" Help/Input

I noticed that the new version of Mission Planner has a separate view for Mission, Fence, and Rally points. I tried playing around with it and it seems to include the new advance no fly zone abilities coming to ArduCopter 4.0. However, after many attempts I am unable to figure out how exactly the different views work. When I switch views - either my main mission or the GeoFence disappears (depending on which views I switch between). The list on the bottom also bugs out and seems to pick a random mode/fence type. In the off chance I can get both to show up - I am unable to push waypoints to the drone. Does anyone know if these “views” are actually supported yet - and if so where could I go to learn about how to use them? Picture attached.

1 Like

I’ve been messing around with the complex geofence/stay out zones in SITL this afternoon and did get it working. I Started in the fence menu, drew a polygon, hit the polygon button again in the upper left and selected Fence Exclusion. This will create the polygon you wish to avoid. I think after that you need to upload those waypoints separately as you would with a mission. Next switch to the Mission tab. Sometimes weird waypoints carried over from the fence screen but I just deleted them and started fresh with the mission. After planning the mission also upload those waypoints. This doesn’t seem to be super stable right now so if you have issues try rebooting mission planner, that worked for me at least.

Make sure you change the appropriate OA params as well.

OA_TYPE = 2 (Dijkstra). You may need to refresh parameters after changing this to see the parameters below.
OA_MARGIN_MAX: the distance (in meters) that the vehicle should stay away from the fences and stay-out zone


Here’s a capture of it in action on a sim mission.

Good Evening,

Thanks for the tips/help. After following your steps I was able to get it to work! Only slight caveat is that I am unable to see the fence when in the Flight Data view (I can only see the waypoints). Do you have any tips for that? It still avoids the fence - but just doesn’t show the visualization. Picture attached - the red line is me showing where the fence is.Capture

I believe the first time I tried I couldn’t see it on the flight data screen either but after restarting MP it showed up.

Sounds good. Seems like I have to restart a couple of times to get it to show both the mission and fence - I think its just luck. However, I am unable to get it to view both the mission and fence (no matter how many restarts) when I have multiple fences set up. I assume this is because MP has never had to do this before - so the feature may not be implemented yet. Nonetheless, this new stuff is really cool and I look forward to tinkering with it more.

It’s worth mentioning I was using the latest beta of MP, so it could have something to do with that

I have the same behavior using MP 1.3.7 stable build, it’s hard to get fence points and waypoints to work together.

I’ve issue with MP 1.3.70 and AC 4.0.1 on 3DR Solo.
it was working, but not now. I didn’t remember what I have changed since the last time (update MP or update Solo from 3.5 to 4.0.1)
Geo fence menu appears when openning MP and no connection to vehicle, it disappears when connected to Solo. I have to restart MP to get geofence comes back.
The last geofence stays in the vehicle so I can’t arm when i’m outside the fence (fence breach).
I try also with my DIY AC 4.0.3 the issue remains.

A appreciate any help and suggestion

sorry for my quick test with AC 4.0.3, it works for AC 4.0.3 in my DIY drone but unlike before to write fence I use write WP as @JDeForest said since the fence menu didn’t exist.
For AC 4.0.1 on Solo, the command FENCE_POLYGON_VERTEX_EXCLUSION is unknown. I don’t know it is AC 4.0.1 issue or it is special firmware for Solo.

Servers by jDrones