Servers by jDrones

New FC: RadioLink Mini Pix

A little of help please? I flashed via MP2 in Ubuntu the Rorver 3.5rc1 in (format BIN I think)
The board entered in a state of green light and it has a flash red when boot for few seconds. While is flashing in red, the computers can recognice it as PX4 FCU.(I dont know if is ther original bootloader or was flashed via MP2)
The thinG is Im trying flash the xxxxxwithbl.hex via BTC (chrome) but dont give me a port to choose in windows, and in linux doesnt work
Do I need force the DFU mode as above with the 3.3v in the pad?To do it I first need connect via usb,force the dfu and flash with BTC,that is OK?

@Andres_Camacho the MiniPix does come with an ardupilot compatible bootloader, a radiolink proprietary one though. while it‘s not the default unbranded ardupilot bootloader that‘s included in the arduvehicle_with_bl.hex files, it‘s not generally required to replace it for firmware handling. you can well use MP to flash ardupilot firmware files only based on the existent radiolink bootloader.
replacing the bootloader however requires booting the board to DFU mode. this board does not have a boot0-jumper or -button easily accesible, so it requires shorting the boot pads as shown here:

Thank you, after all day briked I got make it work and I guess installed with chibios as I flashed the ardurover 3.5 via apj file from the servers for minipix. I couldnt get put the board in dfu and flash the hex files.
Even with you explanation I dont understand what happened or even if I have the right bootloader in my or board.
The apj file flash the bootloader too, or only the firmware.
How I can check if my BL is the right, because all time was PX4 FMU V2. How I can to know if chibios is installed. Can I use now the regular Missionplaner as I have rover 3.5?
Im worry I have the full pixhawk bootloader installed

don‘t worry too much about that bootloader. the default one will work just fine. if you‘ve got regular (non-branded) MP and non-branded adupilot firmware working alright, i personally wouldn‘t bother to replace the existent bootloader.

Another low cost FC for Ardupilot:

You know its From China when they can’t even name it correctly…or is it a new release of Ardupilot ?!?

-100% use Arduploit official firmware, 100% Missionplanner official ground station
-100% support Arduploit compatible various hardware(RTK, GPS)

But seriously there are good components within, just hope the quality is there as well

Why would anyone use that FC? It has all the disadvantages of FC’s with that form factor (annoying 360° I/O) and none of the advantages of small cheap FC’s (Vbatt power, OSD, current measurement, BEC’s, general AIO features). Looks like old recycled stuff to me.

I only signalled, maybe someone is interested.
Anyway Vbatt power, current measurement, BEC are in the included power module. To have a separated power module has its advantages, on some cheap AIO boards the integrated BEC is a source of noise for the rest of the board.
That said it remain to see the quality level of the PCB, components, soldering, …

In my opinion power features better in other board, due to noise or any mistake in wiring. The 360° is no bad or good, but is good the size against the full size PX4. For rover with differents levels, vertical inputs can be a problem,force you to have the the pix4 in the top level.
The conectors are more standars than the minipix I think. It can be upgrades with other gyro, I would like use chibios, im not sure, but probably.
I think just is needed check for the assembly quality. I can be nice for rover, sub or antena tracker, or to work with a small companion.

as for my type of application boards without OSD features lost value noticeably since we have ardupilot onboard OSD, i decided to try and add that to the mini-pix boards i still had in my drawer.

mini-pix does not have SPI pinned out, but it uses FRAM on SPI2. that is a nice to have feature, but not really essential, so i tried and use the SPI2 pads of that additional FRAM chip to connect an airbot microOSD board modified for use on external SPI with onboard OSD as described here: ArduPilot onboard OSD using an external SPI OSD breakout board

i located the mini-pix’s FRAM chip and desoldered it:

from the chip’s datasheet i got the pin assignments:

then i made the necessary adjustments to the firmware. removing FRAM requires some storage layout rearrangements, including the bootloader storage defines. it’s now using MCU flash only, just like other boards that have no additional onboard memory. beyond that, adjustments to main hwdef include replacing the FRAM with the OSD in the SPI device table, adding the required font file includes and trying to not brick anything :wink:
the respective changes can be found here:

luckily it all worked out quite well:

that’s some new value added to this board i most likely wouldn’t have used anymore without the OSD feature.

cheers, basti.

Hi, does anyone know if its possible to set any of the Main Out pins to relay on the Mini Pix since there are no AUXOUT pins? I have the latest arducopter firmware for mini-pix.


@NiharikaPatel the „AUX“ referral for output pins afaik is rooted in fmuvx design standard, using a separate IOMCU for „main“ outputs, while „AUX“ pins are directly driven by the main processor.
on boards without IOMCU like the MiniPix however, all output pins are directly driven by the MCU and allow „AUX“ type use.

the MiniPix 6 pwm outputs are adressed as GPIO 50 - 55 in runtime, so setting BRD_PWM_COUNT to 5 for example will allow to address GPIO 55 as a relay. adjust as required.

1 Like

@vierfuffzig Thanks!! that worked :slight_smile:

All of the pins on MiniPix are aux pins using ArduPilot nomenclature.


1 Like

Is anyone using the RadioLink Mini Pix (v1.0 if there’s more than one version?) with ArduPilot/ArduPlane 4.0.1 and Mission Planner? I flashed the arduplane_with_bl.hex firmware from onto it in DFU mode which was successful. I still seems to be working… red light blinks for a few seconds, safety light then comes on, and when I put a blank microSD in the slot it created an APM folder. But, I can’t connect to it in Mission Planner (STM virtual com port, 115200 baud)… other than trying to update the firmware again. Just times out on ‘connecting to Mavlink’. Using the ‘latest’ version of Mission Planner downloaded yesterday. When I click on the firmware update and firmware manifest sections it detects the MiniPix just fine, and says it has the latest 4.0.1 firmware.

I’ve loaded the firmware multiple times, tried the latest firmware branch instead of stable, and even tried going back to v3.9.10 with no change in behaviour. I was initially trying with no pheripherals at all on the MiniPix, but adding the power board, receiver, safety button, GPS, etc made no difference. I’ve also tried installing Misison Planner on another Windoze 10 machine just in case I’d stuffed up the drivers, after using Zadig to do the DFU programming of the bootloader, but no difference there either! Nor did changing USB cables or ports, just in case.

Any ideas how I make this 'lil @#$% start talking properly? :sob:

Missionplanner has changed it’s drivers. You might need to update them

With a new install though? I can understand that if I was revisiting this, but both machines were installed within the last two days. MP v1.3.69 … so unless I have managed to get the wrong build I should be right? Maybe?

Is anyone using the RadioLink Mini Pix (v1.0 if there¢s more than one version?) with ArduPilot/ArduPlane 4.0.1 and Mission Planner? I flashed the

Yes, I have several of these.

The hardware is flakey, so please be very rigorous in your pre-flight

Any ideas how I make this 'lil @#$% start talking properly? :sob:

Following on from James’ suggestion - perhaps try MAVProxy or
QGroundControl to see if they can talk to it?


I did try QGroundControl, and wasn’t getting anywhere with that, and actually removed both it and Mission Planner, and then re-installed Mission Planner in case the QGroundControl drivers were the issue (removing the driver/device instance via device manager in between to make doubly sure the drivers were re-detected/re-installed). But I’ll try again to see if there is any change.

I didn’t know about MAVProxy, so I’ll download that and give it a try also.

The exact startup behaviour of the MiniPix at present is when the (USB) power is connected, pink light rapidly flashes on the main board for a second, then it flashes red rapidly for several seconds, it goes out, and then the light comes on on the safety button. It is detected as a STM32 Virtual Serial port on both Windows 10 boxes, but nothing I’ve tried so far will actually ‘connect’ to it via USB-Serial @ 115200 baud.

I’m really starting to wish I’d known about the Matek F411-WING at the time I ordered this! :open_mouth: :laughing:

FYI The F411 wing doesn’t work with ArduPilot: F405 and F765 wing boards do though.

Servers by jDrones