Servers by jDrones

New FC: RadioLink Mini Pix


(James Pattison) #42

Seems tridge is a step ahead, and now has one to start looking at ChibiOS support.


(Toto Mauris) #43

Radiolink doesn’t want to provide the source


(Esteve Giribets Moron) #44

Hello everyone. I bought a mini pix from Radiolink on AliExpress. I connected it to mac and apm plannet to load arduplane since I want to use it in a fixed wing. after loading the firmware the computer no longer detects the board. Scared I tried in Windows and the board is only detected a few seconds and then no longer appears in the device manager, which I can not connect to the mission planner. I have tried connecting the battery with the power module and it is not detected by the pc either. I see that the green led of Power if it is on but the red LED turns on only a few seconds until it turns off and stops being detected in some usb port. I tested with 2 different cables and also in another USB port. I am a bit frustrated because before loading the firmware the Mac and Windows recognized the board without problem. What happened? I have broken the board by loading a firmware from the Arducopter apm planner? If you could help me I would really appreciate it.

regard :+1::+1:


(Luís Vale Gonçalves) #45

That board (RadioLink) is not supported (yet)

You have to use the proprietary solution (firmware and gcs) from the manufacturer.

This might change in the future.

edit: Ask the seller for the source code, since it , apparently, is based on GPL


(Toto Mauris) #46

You can find Plane firmware here http://www.radiolink.com.cn/firmware...duPlane-v4.px4

Its plane 3.8.4, its works for me.

Its a proprietary solution, but its works…

To load firmware, you simply have to use load custom firmware function in mission planner (Initial Setup -> Install Firmware > …)

No mavlink connection required

Hope its help


(Esteve Giribets Moron) #47

Hey luisvale thanks for your reply. Now I know I must use radiolink firmware and gsc. But now for resurrect it I don’t know what I must do. If the board was detected by Windows I can update properly firmware. The big problem I how to fix the usb port detection on Windows or Mac. Now I have a brick board :man_facepalming::sweat:


(Toto Mauris) #48

Read my previous post


Dev Call Jan 29, 2018 2300 UTC
(Esteve Giribets Moron) #49

Thanks Mauris for your reply. I will try this afternoon,but if is not recognise by pc i doubt I can charge this firmware. Thanks again to both for your reply I hope I can fix. Appreciate a lot :+1::+1:


(Toto Mauris) #50

When you say not recognize, its OS or mission planner ?


(Esteve Giribets Moron) #51

Is in OS. When I plug the usb no port com of the board is in device manager. Only few seconds I can see the board port com ( com7) but after he disappear of the device manager and red light of the board switch off.


(Toto Mauris) #52

If windows, reinstall latest mission planner (original not radiolink), the install will install drivers…


(Toto Mauris) #53

Radiolnk doesn’t want to disclose the source code


(Esteve Giribets Moron) #54

OMG Yes !!! She is alive :clap::clap:. Do what you say. I connect to Radiolink Mission Planner and try to install arduplane. Pc can read it at com 7 and again red led is flashing continuous. So happy thanks a lot my friend,I was very afraid and frustrated but the solution was very easy. :top::top: thanks bro appreciate a lot


(Luís Vale Gonçalves) #55

Good to know that you managed to get it going.

Now ask for the source code to the manufacturer, as you are entitled to it… :slight_smile:


(peterbarker) #56

Radiolnk doesn’t want to disclose the source code

It doesn’t actually matter whether they want to or not.

It is part of the license they agreed to when they copied the source code
in the first place.

Both ethically and legally they should be giving access to the source code
under the same terms they received it.

The more people that point that out to them the better.

Peter


Visit Topic or reply to this email to respond.


In Reply To

[3060_1.png]
luisvale Luís Vale Gonçalves
January 27 That board (RadioLink) is not supported (yet) You have to use the
proprietary solution (firmware and gcs) from the manufacturer. This might
change in the future. edit: Ask the seller for the source code, since it ,
apparently, is based on GPL


Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

Peter Barker | Programmer,Sysadmin,Geek.
pbarker@barker.dropbear.id.au | You need a bigger hammer.
:: It’s a hack! Expect underscores! - Nigel Williams


(Craig ) #57

Hi Guys,

Same exact issue here. also get a bad sounding tone on boot.

Can someone share the FW as the link is dead above.


(Matt) #58

IMO, this board should not be supported by ArduPilot for all the reasons people have already brought up. If some cut-rate dubious manufacturer wants to steal code, steal designs, build poor quality hardware, and sell it, that should not be supported. Just like they sell other hardware of dubious quality and integrity (like GPS units) that our developers shouldn’t have to waste their time troubleshooting and helping people with. What’s worse, is the time our devs put into it now will go up in smoke without notice when the manufacturer changes something again to lock it out. The dev team ends committing itself to hacking the hack to keep it working.

Now that we have an unsupported hardware category here in the forum, perhaps there should be a pinned post at the top listing known unsupported hardware, and why. If someone buys this cheap garbage, then asks why ArduPilot doesn’t work on it, they can simply be directed to that pinned post explaining it. And it might discourage others from buying it too.


(Dave) #59

It seems they have taken down the links to the firmware and only their version of Mission Planner remains. It must link to their version of firmware directly.


(Chris) #60

I got one of these FCs and tried it out, seems to work ok for flying wing at least. But as already pointed out here the official MP will not flash to it, you need to use the Radiolink MP and their customized firmware so you’re completely at the mercy of Radiolink when it comes to getting any updates in the future.

At first I suspected that the Radiolink MP was just bypassing the hardware check and flashing the standard firmware, but when I checked with packet capture software it is indeed downloading a custom binary from Radiolink’s site. IMO Radiolink should at the very least explain what they did differently in their custom firmware, that might go part-way toward setting people’s minds at ease.

I put my experience with this FC into video here, but beware it’s quite long-winded since this is my first experience with Ardupilot and I covered all the little hiccups I encountered:



Right now it’s performing very well, my biggest gripe is the non-standard plug type, the limited number of connections compared to Pixhawk and the awkwardness of adding any extra I2C sensors. Then again, if it was any bigger it would not have fit in this plane in the first place…


(Gary Mortimer) #61

Thanks for posting that here Chris