Net Framework Error

Well I finally got Mission Planner to work on one computer. It has Windows 7 professional. However my other computer has W7 professional and I also have W8 on a third computer. The latter two refuse to let me load Mission Planner as they come back with the Net Framework 4.0 needed error. I have tried downloading it different versions but no help. I have taken some tips from the Microsoft site but still can’t get it to work on those computers. Well I suppose I will have to live with what I have. Time to install Ubuntu I suppose.

I moved this from Copter to Missionplanner for you.

Try going here and downloading. I think this is the correct version. Works on my W7 Pro PC


Hi Joe, I tried it and it says no longer available

Sorry- I just pasted from a prior post I had when it was there! Didn’t try link yesterday
Gotta love MS…

maybe here?


Okay that link worked and I downloaded version 4.0 installer. But when I go to install it it still says a higher revision is already present and it aborts. Meanwhile Mission planner still tells me it can’t find NET Framework 4.0, so somebody is not leveling with me here. Yes I have lost respect for Microsoft. Since Bill Gates left I wonder if anybody isstill up there driving the bus?..Vince

Try to install 4.6.1 or higher version.


Okay, I was able to install 4.6.1 net framework and that fixed the problem! Mission Planner appears to be working on both of my Window 7 computers. I am still having a problem installing 4.6.1 on my Windows 8.0 laptop, but the error is corrupt registry. So far Malware bytes can’t find a problem nor does the Microsoft app suggestion. Any ideas how to handle that one?
Meanwhile thank you much all that have led me to success!!!

I just installed 4.6.1 to fix this problem on my Surface Pro, but I had to install 4.6.2 to make it work. Fortunately, after installing 4.6.1, I got a message telling me to use 4.6.2

My tablet with windows 8 have .Net Framework versions 1.0, 1.1, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4,7.1 according to .Net Framework Setup Cleanup Utility.

There is no “my document\mission planner\config.xml” file. No even folder"my document\mission planner" I have no other folders in My documents.

Cleanuping would not work because .Net Framework preinstaled in hte Windows. Updating would not work and i can`t get lower version installed.

Tablet: Windpad 110w-012ru

Is there any other option to install System.Speech, Version= or swith off the downloading in config?