Need help with AUX Outputs for Servo Control

Hi all

I need some help getting servos connected to the AUX ports on my Pixhawk working

I am running AP3.3

I am using a 10 Channel receiver running in PPM

PPM out is connected to RCIN on Pixhawk

Servos are connected to AUX 1 & 2

Servo rail is powered by a BEC

In mission planner I have set RC_9 & RC_10 Function to 1 (Pass Through)

I have set channels 9 & 10 on my Transmitter to 2 switches.

And that is as far as I have got, I cannot get the two servos to respond.

I have probably missed something obvious, can anyone offer any help as to why the servos will not work.

Thanks for any help


That should work. Did you try it with the safety switch pushed. Did you set your radio to output 10 channels?



Thanks for the reply

Yes Arm Switch Pressed and radio set to 10 channels



I just did a test and it works for me. Do you have BRD_PWM_COUNT = 4.

I have a quad so I also tried CH6 and that works also after pushing the safety switch.


Thanks for trying

I do have BRD_PWM_COUNT=4

Safety switch on and no servo, even armed and still no servos.

Very odd.

Maybe save your params to a file and upload a link to it and we will have a look at it.