Need Help, Upload FW without USB

Dear all,
My pixhawk allready fw of px4io upload via Qgroundcontrol.
So QGC very difficult with me, I want upload fw from Mission Planner, But now Usb broken when I put strong on it
Did you know how to using Mission Planner upload fw from other port ( ex Telem1, Telem2 or Serial4/5)
Thanks for help.

I think the bootloader is only accessible from USB and flashing firmware via serial ports isn’t possible.

You can attach an external USB port however…

HI @juzzle1,
I see in schematic of pixhawk, the pin in usb connect direct to extender usb.
And I make the cable plug direct to extender usb, but have same error : usb malfunction.

Who know up fw to pixhawk without USB help me

Have you tried connecting via sik radio modules?

Yes, I try, but can’t update fw

I might appear obvious, yet, maybe there is a way to repair the usb connector on the pixhawk? Maybe try other usb ports on pc, try uploading different fw first. Try uploading ardupilot stack from QGC.

Thanks @Anto6ka,
I trying to weld mini usb port, but not diffrent, and mod the cable connect to External Usb so happend the same. May be it died IC interface usb NUF2042FU6.

if you broke the USB port (i.e. you don’t have a problem on the windows side) and the secondary USB connector on the pixhawk is also broken (because the USB chip got fried), then you’re probably out of luck, sorry. Time for a new board.