Need help troubleshooting No GPS / Need 3D Fix

My 3DR X8+ has just stop getting a GPS signal.
Worked just fine yesterday and days before. Successfully completed dozens of missions just lately

After “inconsistent compasses” message I did a calibration. Still no GPS signal.

x8+ uses 3DR uBlox GPS+MAG LEA6 V1.2, that uses LEA-6h-0-002 u-blox 6 GPS receiver module.
Power LED on the uBlox is ON. FIX is permanently OFF.

I’ve used “MAVSerial pass” feature of the Mission Planner to connect to u-blox 6 via u-center.

No FIX at all.
ZERO satellites.
Sometimes it shows totally irrelevant Lat/Lon and Datum
Showed FIX = INVALID just once.

Updated the firmware of u-blox 6 with this bin

Still no luck.

Please suggest troubleshooting steps.

From what you have described the GPS is still powering up and being seen (No Fix message rather than NO GPS message) but not supplying data.
First step would be to change the cable for a known good one.
Next would be to check you GPS configuration parameters in the Flight Controller to see if anything has changed.
And then check configuration in GPS with something like 'UCentre’
Last resort, slip the battery out and let the GPS settle overnight so it will has to do a cold start next power up.

Or just swap in a new GPS

I did that and it worked.
Thank you.