Need help connecting 8-bit AlexMos gimbal to Omnibus F4 V2 pro

Hi guys, I am trying to connect an alexmosGimbal to an Omnibus F4 V2 pro FC.
The gimbal is on 2.2b2 version and it doesn’t support mavlink protocol.

Please help me understand the following points:

  1. By connecting the gimbal to the FC, how would i be able to control it? Would i be able to control it via the RC?
  2. The copter documentation suggests to connect the gimbal to the telemetry port. Why? Can’t I connect it to any other port?
  3. How are the serial ports assigned on this FC. As per the following image, I can see serial0(usb), TX1/RX1 (serial 1?), TX3/RX3(serial3 ?) and TX6/RX6 (serial 6?). But then again this documentation mentions:

In contrast, this image seems to say rx3/tx3 is uart3:

source :

God! this is confusing… :pray:

Ignore the telemety ports just connect it using the rc channels

Actually I am using an FrSky x-rxr receiver. so no extra channels to controls the gimbal.
I could upgrade but i want to solve this config. No matter the frustration :tired_face:, this helps me to learn.

Just plug the gimbal into the pwm5 and pwm6 ports then set servo5 and 6 servo function to rc passthough to get your gimbal controlled from the rc input.

1 Like

oh ok. you mean using the softserial connections. will try that thanks.

Soft serial isnt a thing on ardupilot. That manual you are using is for a different flight control software.

Thanks geofrancis. In search for the solution, i went through a lot of resources whereever i could find info about various ports on the FC. I thought this was a universal concept about softserial.
I will try setting up the pwm5 and pwm6. so this would allow me to control the gimbal via RC.
Also i think if somehow I am able to make the FC control the gimbal, i could access other features ?
Can you help me with the other questions:


Follow this but don’t select to stabilize pitch or roll so the gimbal does the stabilization that will let ardupilot point the camera rather than just RC.

Thanks @geofrancis, that worked. I connected the pitch/roll via the pwm5/pwm6 and am able to control the gimbal via the rc.
I haven’t tried controlling it via the FC. I will do that next and update here.

Also can you pls share your thoughts on the following:
The copter documentation suggests to connect the gimbal to the telemetry port. Why telemetry port? whats so special about it?


Hi, could anyone pls help me understand this?