Servers by jDrones

Near fly-away. Altitude problem


(dellarb) #1

Had a scary near fly-away today flying ArduPlane on a X-UAV Talon air-frame. Setup is Pixhawk 1 with usual GPS, Compass, I2C Airspeed, PM and 900Mhz telemetry. Talon has flown many missions with no problem and flew a 45 minute flight right before this one.

Launch was an auto take-off thrown by hand but after a few seconds the altitude read out dropped to 0 yet the plane kept executing a full power climb and was visually clearly climbing normally. As the altitude was near 0 the take-off waypoint didn’t complete so the plane went shooting off over houses. Eventually managed to switch to RTL to get it to navigate back but could not stop the full power climb (by the time it was back, it was too high for RC take-over)

Remembered that there is a alt_source parameter which I could adjust to use GPS as alt source which worked (final climb altitude once I switched to GPS was 887 metres!) Airspeed read out seemed to not make sense either at this stage.

Once altitude was valid I could get it to descend and managed to land intact which was a relief. After many checks of everything couldn’t re-produce problems on the ground and did another flight afterwards which worked normally.

Have attached both logs below, really keen to identify if this was a sensor failure, driver issue, EKF issue as it was pretty scary.

(Note that the t-log has two UAV in it as this flight was intended to be a test of some docking approaches. You can ignore the quad-copter on the ground as we never armed and took off as were focused on the main fixed-wing)

BIN Log
https://nextcloud.westcoastuav.org/index.php/s/9RrHNmqC0lX19iK/download

Tlog
https://nextcloud.westcoastuav.org/index.php/s/H9nPibmIUSeJ4O4/download


(lucamax) #2

Hi,
it seems that you have two barometers, Baro2 worked while Baro1 no.

Probably you had set as primary barometer Baro1 .

Do you have a Zubax Gps which has a barometer on board ?

Max reached altitude was 907 meters !


(dellarb) #3

Hmmm I only have a regular Pixhawk 1 and was running a NeoM8N so no second barometer. How would that have appeared randomly on a given flight?


(lucamax) #4

Look at GND parameters ., there must be something wrong there.

If you look at your Logs you will see two barometers.
Baro2 worked perfectly.


(dellarb) #5

Ah I see. Is there ever a baro2 in a Pixhawk 1? There is definitely nothing externally connected, only accessories were the M8N, I2C Airspeed sensor, normal 3DR power module and 900Mhz telemetry radio.


(lucamax) #6

No, it is quite strange because the barometer is hard detected by the Pixhawk.

In fact GND_Primary parameter can allow to assign one barometer as Primary but between the detected barometers, somehow it seems that your Pixhawk detected more than one .
You should post in the Pixhawk section and ask is someone had the same problem.

The only time when I had a second barometer it was with Zubax Gps that has an onboard precision barometer.

Anyway my compliments for being able to recover from a such extreme situation, well done !


(dellarb) #7

Thanks for help diagnosing, have invited Tridge to take a look hope that is appropriate process as I am flummoxed as to how a phantom barometer could be showing up and causing such an issue. Can only guess it might be driver code or in the ArduPlane code somewhere.


(Kikislater) #8

Do you have Pixhawk 2.4.8 or original 3DR ?
Some seller on ebay or other have pixhawk 2.4.8 with wrong baro. 5607 instead 5611 : difference is around 500 hpa.


(dellarb) #9

Kikislater - no it’s actually a regular 3DR one, even if not, the wrong baro wouldn’t explain the appearance of a phantom second one though would it?


(John R) #10

Without opening up the case, is there a way to determine what baro you have?

thanks!