Servers by jDrones

Navio2 - Check BRD_TYPE: INS: unable to initialise driver

Hi !

I’m having issues with my Navio2 with ArduPilot 3.6.11 (using ArduCopter for a quadcopter)

1. I get this error message constantly : Check BRD_TYPE: INS: unable to initialise driver


I can’t find where BRD_Type parameter is and even if I found it, I wouldn’t know how to make it work for my navio2 board.

2. I think that is a result, but when I try to calibrate my controler there is a message telling me "Detected 0 radio channels. To operate PX4, you need at least 5 channels"


However I don’t have a PX4…

QGC (on my tablet) is connected to the transmitter via bluetooth, so I’m connected to the navio via radio link (as shown below).

Thanks in advance for your help !

The BRD_TYPE error comes from the vehicle firmware. So you’re better of asking this question on a firmware forum where you’ll hit more firmware folks.

Yes, as @DonLakeFlyer pointed out, the parameter in the firmware BRD_TYPE has not been set correctly.
You can set it manually in the parameters list.

BRD_TYPE: Board type

Note: This parameter is for advanced users

This allows selection of a PX4 or VRBRAIN board type. If set to zero then the board type is auto-detected (PX4)

Values RebootRequired
Value Meaning


0 AUTO
1 PX4V1
2 Pixhawk
3 Cube/Pixhawk2
4 Pixracer
5 PixhawkMini
6 Pixhawk2Slim
7 VRBrain 5.1
8 VRBrain 5.2
9 VR Micro Brain 5.1
10 VR Micro Brain 5.2
11 VRBrain Core 1.0
12 VRBrain 5.4
13 Intel Aero FC
20 AUAV2.1 True

Since you are using navio2, the message is actually wrong since Linux boards don’t use the BRD_Type parameter. It should be left as Auto if you see it.

I recommend updating to master branch and trying to check if it’s working. Chances are you have a faulty navio2 or it’s not tightly connected to the rpi.

I think it could have something have to do with the radio link. The BRD_TYPE should be zero and that works fine on my Navio2. But maybe try connecting with regular telemetry radios on either /dev/ttyAMA0 or /dev/ttyUSB0 (depending on the connector type on your radio) first and do the setup with that. And using a regular SBus RC receiver too.

Then try to get the TBS Crossfire working after you have everything configured and known working. It doesn’t look to me like the Navio2 is even detecting any RC channels thru the Crossfire link and I have had problems with this with both Crossfire and DragonLink in the past. Especially the DragonLink is very buggy on Bluetooth. It’s been awhile since I played with Crossfire.

Thanks to all of you.
I solved the problem by installing the QGC Daily Build app…
No comments, electronics can be very weird sometimes…

Servers by jDrones