Servers by jDrones

Navigation turning performance issues

arduplane
pixhawk

(T ) #1

I can’t seem to overcome some issues with the accuracy in AUTO mode navigation turning. I can turn my aircraft pretty tightly in FBWA, but I am not seeing the Pixhawk control the turns very tightly in AUTO mode. Can @Tridge or someone with navigation tuning expertise please help me improve the performance?

I am looking to build a fixed wing survey drone. I used a Horizon Hobby Apprentice S that I already had for a temporary airframe for my initial controls testing. I am considering something like a Finwing Sabre for an airframe that can carry a decent payload to do survey work. Any future airframe suggestions are welcome.

Main Components
Apprentice S
mRobotics Pixhawk 1 running Plane 3.8.4
Battery monitor
E-flite 1030B ESC
Spectrum AR610 Receiver
PPM Sum receiver
Digital Airspeed sensor
Telemetry Radio

I read the log analysis case studies by Tridge and have done some work with servo gains and NAVL tuning parameters. I have adjusted LIM_ROLL_CD, Roll P and Roll I. I have adjusted NAVL1_Period, NAVL1_Damping and WP_Radius.

These parameter changes have improved the performance, but there are still some issues at the end of a survey grid row. I still see overshoot and inconsistent turns. You can see in the last image I loosened up the WP_Rad and the turns got smoother which make sense on some, but on some rows it turned more sharply. I have added in a 100M Lead-in and Overfly to the rows. That helped to ensure the survey waypoints are achieved. The last image show the difference that it makes.

Any suggestions to smooth out turns?

Waypoint path and the telemetry flight path for a plain square:

Waypoint path and the telemetry flight path for a ‘Alternating WP Row Survey Grid’:

Waypoint path and the telemetry flight path for a ‘Alternating WP Row Survey Grid’:

Waypoint path and the telemetry flight path for a ‘Alternating WP Row Survey Grid’ & 100M Lead-in/Overfly:


(***) #2

This is an excellent post, have been fumbling with this myself, seems like the UAV is slightly drunken in auto mode doing missions. Will be curious to hear what the experts have to say!!!


(Paul) #3

Flying slower helps it to track better.


(lucamax) #4

I would set L1 control Period at a lower value than 12.


(T ) #5

Thanks for the feedback. The turning behavior is kind erratic. It is not very smooth and not as good as I can get when I use FBWA mode. The survey row path achieved pretty good accuracy when I added in the Lead-in and Overfly. I am hoping that @Tridge can help me to smooth out the turns though.