Nano Radar Not working on Pixhawk Cube

Hello everyone,

I am trying to make an obstacle avoidance drone with a nano radar.The exact specifications of the radar are as followed:

77GHZ Nano Radar
UART Interface

And the flight Controller is the Pixhawk Cube Orange Plus

In the documentation it says to change the telem2 protocol to the Lidar360(serial2_protocol=11) option which I did.Also,it says to set proximity type as Tera Range Tower it(PRX1_Type=3)The problem I am facing is as followed:

PreArm:PRX1:No Data

I do know the nano radar is working as I am recieving data on a TTL USB connected to Serial Plotter on PC.

If anyone can help in this issue that would be great.

For more effective communication, you should add a link to the radar.

Right,here is the link for the radar:

77GHZ Collision Avoidance Radar MR72_Nanoradar-Accurate Measure Intellgent Sense

Set PRX1_type to 6…it will detect radar data

Sadly no.Tried it and still gives the same ‘No data’ response.

What is the serial2 baudrate you set and have you restared flight controller after those setting?

According to the documentation, it says to set the baud to 115200(serial2_baud=115).I did that.Also yes,I do restart my flight controller after changing the parameters each time.

When you buy mr72 radar have requested OEM to change the firmware to work with ardupilot flight controllers, generally normal MR72 doesn’t work with pixhawk as plug and play…radar firmware need to change.

If that also done have you powered radar by isolate Power supply from external source not from flight controller itself.

1 Like

Yes, I have tried with both external power supply and powering through the flight controller. And yes, I did ask the OEM if the firmware is to my specifications. Will update when I get a response.

So, either the firmware needs to be changed or I am going to need a companion computer (CC) along with the radar to read and send data to the flight controller.

Is that right?

Alright so an update.

I have checked with the OEM and the protocol to follow was CAN, not UART.
So I have changed and now I am getting a new message which I don’t know is a step forward or not.

Bad Proximity

I am following this thread as I found it similar to setting up the radar:
Application of TF03 CAN in PixHawk (ArduPilot Firmware) - Blog - ArduPilot Discourse

Second update:
Got the Nano Radar working.The protocol is UART as before,not CAN.My mistake.But the bad proximity error still remains.Probably just a loose wire or the power reaching the nano radar is less than 12V.

Hi there,
I am also trying to work with an mr72 radar. Did you change the comm protocol from CAN to UART ?. If so ,how can that be done. The radar with me now is giving data in CAN protocol.

I didn’t, the module I received was in the UART protocol. This module comes in two versions, one that has CAN protocol and another with UART protocol. It can be changed by opening the casing and rewiring the connections however no datasheet is available so I would strongly suggest against it.I have yet to do some testing on my own of rewiring it.

I am working on the same.
Could you share the ardupilot documentation and other useful resources?

That would be a great help for me

Thanks in advance.

The only document I could find was the user manual for it on the OEM website:

Hi there,
Just wanted to ask if you have tried using the bendy ruler parameters for obstacle avoidance.

Not yet,the main problem right now is that the connection suddenly breaks between my radar and the PX Cube.It works fine for like 5 to 6 seconds then no data arrives.Still trying to troubleshoot that.

Is your mr72 radar working with pixhawk properly or not because mine not working and what it’s protocol???

Try change the PRX_TYPE = 6 (TerraRangeTowerEVO)

Thank you
Now it’s working.

@Sanatan_Biswal Can you please tell all the steps you took to get the MR72 to work with mission planner?

I have the MR72 connected to the pixhawk via telem2, and am not getting radar data in mission planner.