Nano Goblin VTOL project, help/advice needed

Reposting here as it looks like this forum is more on topic.


Just getting acquainted with Ardupilot and have hit a few stumbling blocks.
First, the setup:
Arduplane 3.9.6
Strix Nano Goblin (580mm wingspan)
Matek F405 Wing
Spedix 45A plane esc
Racerstar 35A 4-in-1 esc for the quad motors
PUAV 1306 3350kv motors for quad
Cobra 1407 3500kv motor for plane
TBS Crossfire rx
TBS Unify HV 5.8ghz vtx
Runcam Owl v2 flight cam
Tattu 1050mah 4S lipo

Quad is set to H frame type, I designed the connecting bits in Fusion360 and printed them on an Ender3. The plane hovers but is still a bit squirrelly.

Need to run autotune, so here’s problem 1:
The Q_AUTOTUNE parameters don’t show up for me in the full list. I set Mode 6 to “22” per the instructions here: QAUTOTUNE - VTOL autotune for quadplanes . In the Flight Mode tab, Mode 6 is blank in its dropdown. In full param list there are no Q_AUTOTUNE options. Wondering if I should just load Arducopter, tune, then transfer the PIDs to the quadplane profile.

Problem 2: everything works properly except roll on the elevon servos is reversed. The radio sticks move the quad properly in every direction. Stabilize moves the quad correctly as well. Stabilize moves the plane servos in the correction direction in both pitch and roll, all good there. BUT, when moving the radio sticks, roll is reversed in the servos. Pitch moves as it should. I’ve tried every combo of reversing the channel in the radio and the FC but can’t get EVERYTHING to react properly. Just roll is off. So frustrating as it’s sooo close to being ready to maiden.

Any advice would be greatly appreciated. Thanks!



I’ve just tried flipping all options of the two servos, between direction and function. None of them work as I would like. I’m left with two scenarios:

  1. Flight controller stabilizes servos correctly in pitch and roll; sticks move pitch correct, roll backwards.

  2. Flight controller stabilizes servos in pitch correctly but roll is backwards; sticks move servos correctly both pitch and roll.

If I reverse the roll channel on the radio, the quad doesn’t fly correctly. So, it seems I need to get it set (some how) in the FC.

Is it possible to reverse a servo direction from an rc switch? Ex: when I flip from QHOVER to FBWA, the mode switch would also reverse output to servo 4.

1 Like

first thing to check is you rc stick calabrations

note the tip, all green bars should move in the same direction as the sticks except pitch.

you will only have auto tune on the latest release, its not made it to stable ye, you will also have to be on the mission planner beta to get the matching param descriptions

1 Like

Thanks for the suggestion. I reversed a channel in the radio then reran the radio calibration in MP. Now everything moves and stabilizes correctly. Problem 2 solved.

I have the latest from Mar. 4 loaded but still don’t see the params. No matter, can load arducopter and get autotune pids from there.

1 Like

I noticed you’re using a 4 in 1 esc for your project. Is there any reason you went with the racerstar or any issues integrating it with your FC or PDB, those aren’t listed in your build list.

1 Like

Hi Justin this is a great project,im going to copy you and thank you for the idea got most of the parts now just need a couple,would you be able to share the files of the rear motor mounts please and I will get a friend to print them,cant wait to try and get it flying the nano goblin is ace and this project is the ice on the cake

Hi Martin,

I’ve uploaded the files here (with pics/vids):

Let me know if you have any questions!

I went with the Racerstar as I thought I would stack the FC and ESC, so both needed to be 30x30. Once I got the build underway I realized there wasn’t enough room beneath the wing spars for stacking. So, I could have used a smaller 20x20 ESC. Not a huge deal though, I can rip the electronics out of this and place in a much larger plane without having to redo anything. All the gear is rated for 6S.

As far as integrating goes, the printed pinout sheet that ships with the Racerstar doesn’t match their online pinout. Took a bit of swapping motor leads to get it sorted out. Works fine otherwise.

1 Like

thanks for that Justin will be ordering ESC on Friday what amp 20x20 one do you recommend please ive got some tigre F20 1408 x 3750 motors here im thinking of using

I was hovering around 8-10 amps. I wouldn’t go lower than a 20a esc, just to have enough overhead.

1 Like

I’ve had great luck with Spedix escs, I’d prolly go with this one:

1 Like

Im hoping to order the 25amp speedex 4 in 1 ESC Justin,waiting on my printed parts to arrive

That’s awesome. One note: the rear motor mounts are a pressure fit onto the 3mm spars. If they fit loose at all, add a thin layer of liquid electrical tape to the last 10mm of the spar to fill the gap in the mount. Make sense?

1 Like

thanks for that any particular glue you used ive got the usual,por,araldite and super glue really looking forward to this ordered all the carbon did you use a GPS with a compass

This is the LE I’ve been using: I like using this as it’s easy to remove if you don’t like it but also adds a little vibe dampening between the spar and mount.

Yes, this GPS has a compass:

1 Like

thank’s,ive got a matek gps with compas I can use will look for similar liquid tape hear and get ordered

Hi Justin. In case you have not solved the problem number one. I think you are trying to use latest stable version. You need a developer build called “master” it is sort of an “alpha” build. This is the version with the autotune in it. Please use at your own risk. If you need help with how to get it uploaded, then feel free to contact me in a private message.

Well done with your project. Good job. I have something similar in mind.

1 Like

Thanks. I’ve got a Latest build from the other day loaded. Autotune still doesn’t show up on the flite mode UI in MP (displays as blank) but the Q_AUTOTUNE items do show up now in Full param list. Hoping to give it a try in the next few days if the weather cooperates.

1 Like

Latest master? (not stable, not beta). Sorry for asking again. You keep saying latest, but never once confirmed that it was master (Development) build.

Should say v3.10…, not 3.9.

1 Like

Got it from here:

Says “APMVERSION: ArduPlane V3.10.0-dev”

Still learning the terminology, apologies!

1 Like