Mysterious shutdown in the air

Hi all,
Our drone had a “catastrophic failure” a few days ago, and we want to find the cause of the incident. We lost the drone in the incident, meaning I cannot provide the full flight logs. However, the ground station saved the streamed data, and it’s all the available information about the flight we have now to investigate the incident.

Looking into the tlog, we found that the first sign of malfunctioning was the V_servo going dead about 3 seconds before the complete shutdown. Also, the battery voltage dropped 1V ish during that short period. Our strongest hypothesis is that there was some sort of short-circuiting in the carrier board and that cascaded to a complete shutdown of the autopilot. We tried to replicate this pattern on the bench by purposely short-circuiting the servo rails, 5V outputs, and even the motor cables, but the drone kept running as if nothing happened. Our tests showed that the drone is safe but something else went wrong that may be out of our control.

I’ll appreciate if anyone here can take a look at the logs and confirm our findings. It’d be sad if the failure was caused by a defect on the carrier board.

Also, here are some specs and stats of the drone:

  • CubeOrange-bdshot version 4.1.5 mounted on a mini carrier board
  • Lumenier 4-in-1 35A Bl_Heli32 running dshot600
  • mRo ACSP5 power module
  • 18 flying hours were recorded with this drone until the incident

Link to the tlog:!ArMDLLLI-JmigZkp0ncu55g0yCcACw?e=5sOk3N

Thanks for your help!

I’m so sorry for your crash.

but the file is not opening well.

I tried downloading the file from the link and it works fine with the online UAV log viewer and even replaying it on Mission Planner.

did you find any reason caused this accident?

was there some payload that consumes amphere?

it would be helpful to upload photo or diagram of wires.

and when I connect to the link you gave me, there is blank screen on chrome.

If I wait on web page, they say there is problem on the server.