My QuadPlane motor won’t spin


I’ve read this:

and it seems like a potential reason for this is that I’ve got my servos/motors connected into the wrong PWM output groups. Do any of you know what the groups are? I contacted the manufacturer to ask as well. Do you think this could be the issue?

Hey everyone, this is my first post.

I’m building a VTOL QuadPlane and facing big problems! In QStabilize mode, all four vertical motors spin nicely when armed. However, in manual mode the horizontal ‘forward flight mode’ motor won’t spin or arm. All 5 ESCs are DSHOT600.

Before you start troubleshooting, here’s what I’ve figured out so far. It’s not some mismatched ESC issue, because all my ESCs are the same. It’s not a power issue, because the ESC is giving the beeps indicating it’s getting power. It’s not a FC issue, I’ve swapped those out. I feel like there’s some hidden parameter or setting I don’t know about that let’s you calibrate / arm the horizontal motor on a QuadPlane. Any ideas?

Have you tried calibrating the ESC’s?

Verify if the forward motor ESC is indeed connected to the Main Output 3 and the ground wire of the ESC PWM connector is on the top, assuming you’re using a Pixhawk Cube.

I think the issue might be that the forward throttle output (Main Out 3), is configured by default for normal PWM output and not DShot. I’ve always used a traditional fixed wing ESC on the forward motor so I’ve never had to change this, but I think this is what might be causing your issue.

I found the following, albeit in the Copter docs, which might be able to help you since you’re using a DShot ESC on the forward motor as well:

Further down the page, it also mentions that DShot won’t work on the MAIN outputs:

In that case you’d have to remap the throttle output to one of the AUX outputs and then change the settings to output DShot on that AUX output.

Check it out and see if it makes sense, meanwhile others who have done this can chip in and correct me if I’m wrong.

If you have one, use a normal fixed wing ESC and see if that solves your issue. As far as I can tell you will probably not notice significant difference using a DShot ESC on the forward motorx so you could save yourself some hassle by using a normal ESC.

Hope this helps, cheers!

Yes. Calibrated successful, didn’t help anything

Thank you so much for such an amazing answer, I greatly appreciate it!!!

So I’ve tried using a ‘regular’ fixed wing ESC , and same exact issue. I’m using a Matek F405 WING not a Pixhawk :confused:

Do any of you know what the groups are?

From the Copter docs for the F405-Wing:

Correlating the above from what I see on Matek’s page:

The groups seem to be:
S1 & S2 on timer TIM4 - Aileron and Elevator for ArduPlane
S3 & S4 on timer TIM3 - Throttle (forward motor) and Rudder
S5 & S6 on timer TIM8 - Quad VTOL motors 1 & 2
S6, S7 & S9 on timer TIM1 - Quad VTOL motors 3 & 4 and output AUX 1 (correlating the Pixhawk’s pinout)
S10 on timer TIM2 - AUX 2

So if I’m reading this correctly, S3 & S4 (Rudder) need to be changed to DShot outputs. I’m not aware how servos behave with DShot enabled (since you’re enabling DShot on the rudder output) so you could try and see what happens.

So I’ve tried using a ‘regular’ fixed wing ESC , and same exact issue.

Verify the following parameters:
SERVO3_FUNCTION = 70 for Throttle

What happens if you connect the DShot ESC directly to your RC Receiver? Also, does a normal ESC work when connected directly to the RC Receiver?

You said that in QStabilize vertical motors arm and spin, this means that it’s not failing any PreArm checks. You could still take a look at the Messages tab in Mission Planner (bottom left) for any info.

Additionally, with the props off, try connecting the forward motor ESC to any one of the vertical motor outputs. Then see if the forward motor spins up along with the other vertical motors in QStabilize. You could also swap each of the vertical ESCs into the forward throttle channel one by one and observe if the same issue persists.

This would help eliminate:

  1. The forward ESC being faulty
  2. The forward ESC not receiving power from your power distribution
  3. Any issues between the forward ESC and the forward motor.

Hey! That’s amazing, this worked. I found the timing groups as well, and did a similar thing to what you suggested. It works great on the bench, now I’ll have to setup all the sensors and etc and hopefully we’ll get flying this weekend! I’ll post some pictures of the maiden VTOL flight back here, so stay tuned😁

1 Like

Awesome, so changing S3 & S4 to DShot is what worked? And rudder works as expected?

How do you calibrate with DShot? I saw a previous post saying you did not need to perform calibration but…obviously i’d like confirmation.

You don’t calibrate with Dshot.