My plane dives hard when turning in AUTO mode


I am trying to configure a X8 wing with APM and airspeed sensor installed. It flies well in Stabilize, FBWA, FBWB, and RTL. My problem is when doing an AUTO mission, the plane does most of the turns very well, but in some turns it looses a lot of height.

I attach a LOG file of a flight in which it happened two times in two different turns. All the other turns were done perfectly but in these two turns the plane lost about 40 meters in each one. In both of the turns there was some wind from south-west, so when the turn was being done, the plane had some tail wind. The wind that day was about 8 m/s or less.

I have tried analysing the log and i can´t determine the cause of the height loss.

Thanks a lot for your help!


I had a similar problem with an X8 a few years back and ended up having a lot of discussion with the developer Paul Riseborough about this.

My take on it eventually was as follows: when the plane senses that it’s loosing altitude the throttle ramps up as is the convention to gain altitude, however in the X8 it just flew faster, with the motor actually pushing the nose down and the foam elevons bending due to the aerodynamic forces on them, the small amount of up elevon added was thus lost.

To me it seemed there wasn’t enough ‘yank’ in the ‘bank and yank’ part of turning. It always seemed worse on the downwind part of the turn and also worse in stronger wind. It could develop into a runaway type of situation where the increasing speed kept the nose down and the plane would try to go faster and faster to gain height (the plane exceeded 140kmh ground speed in one episode).

I solved it with a number of things:
Increase the pitch P value much higher than you think. (ie, tune the pitch loop aggressively)
Ensure compass and airspeed are working properly
Give the motor at least 5° upthrust. You want the plane to climb with throttle in Manual mode
Put stiffer pushrods and perhaps beefier servo’s (I didn’t, but you could change the foam elevons to balsa).
Try slow the plane down a bit. (Reducing Max throttle temporarily solved the problem)
If those don’t solve the problem, you can try increase PTCH2SRV_RLL from 1.0 to 1.2 or 1.3, this however can cause ballooning when coming out of the turn.

Hello again an thanks a lot for your time!

The problem seem similar as the one described by Graham. I can try increasing the PITCH2SRV_P. The motor now is quite horizontal and I think it doesn´t give up or downthrust. In manual mode the plane tends to climb slightly with the trimmings I have.

My ailerons are stiffened with carbon rods so they are not very flexible and my servos are very strong.

My PTCH2SRV_ROLL is at 1.1, but I don´t know if increasing it would solve the problem. I think TECS_SPDWEIGHT could help solving the problem but I don´t know really if I should change that value.

I am not an expert analyzing the log files, but I have been trying to understand them. I have been analyzing the TLOG, and I have discovered that when the problem occurs, the artificial horizontal of the TLOG seems incorrect to me. It seems that the plane thinks that it is pitching up but the plane is really pitching down because it is loosing a lot of height. I think this is wrong but I am not sure and I don´t know how could I change this in case this was the origin of the problem.

I attach the TLOG of the same flight.

[attachment=0]2015-09-30 19-09-34.tlog[/attachment]

Yes I had that too, ie the pitch estimation being clearly wrong but I think that’s a different problem to the one I mentioned above.

I’m just looking through my correspondence with Paul to see how/if we solved the problem.

It was clear that at one point the FC reported a pitch angle of +30° yet the altitude was decreasing so it could not be pitching up at 30°. I’ll have a look at your log and see if I see the same symptoms.

I see the same symptoms: pitch increases from +11° +43°, Alt from 977m to 927m (50m loss), airspeed from 14-21m/s and groundspeed from 12-35m/s, so it’s clearly descending and speeding up but reporting 43° nose up.

(Deleted, not relevant)

Going through my old emails it seems the problem disappeared when we changed to Pixhawks and started using EKF. What FC/firmware are you using and is EKF enabled?