My pixhwak 2.4.8 PWM outputs don't work

Hello everyone, I am new to these topics although I have documented a lot of these forums and courses that I have acquired.

I have the next problem. I have the autopilot PixHawk 2.4.8 wich I bought by Aliexpress with its complete kit. The PWM outputs don’t work, or at least they seem don’t work. I’m trying to build my own drone following tutorials in youtube and Udemy (I bought the course “Make an Open Source Drone”). All of these videos show the same steps and I do exactly the same steps but my pixhawk seems to have a problem with PWM outputs when I try to calibrate ESC’s 30A or Calibrate my radio-control with mission planner or QgroundControl. I’m trying to build a drone with F450 frame, A2212 brushless motors, 30A ESC’s (yellow ones, the brand is hobbypower, but some generic 30A ESC’s don’t have brand but they seem similar and are yellow). And my radio-control is Flysky FS-i6 and the receiver is FS-iA6B.

Let’s check the next: If I put my FS-iA6B receiver in PPM out-put mode (from the radio control) PixHawk seems to detect the signal and make a positive or acceptance sound, and the green bars appear on the screen of mission planner and I can calibrate my control. But if I change my FS-iA6B receiver in PWM out-put mode (from the radio control) my PixHawk makes a negative r rejected sound and the green bars disappear from the screen in mission planner and I can’t calibrate my control. I have bonded my FS-iA6B receiver to the RCIN pin in the PixHawk and the CH1 of the FS-iA6B receiver (In all tutorials the people bind both like this) and this could work due to the ESC’s work with PWM output.

On the other hand, my 30A ESC’s work very well. I have calibrated manually with my FLYSKY FS-i6 and the FS-iA6B receiver (with PWM output and channel 3 due to is the throttle) and worked very well. If I calibrate all in once with PixHawk it doesn’t work with PWM output (from my receiver) but if I put my receiver in PPM output it works, but when I disconnect my battery it seems like I would never calibrate my ESC’s.

I have checked forums, Ardupilot page (parameters and problems), youtube videos, and ask for help with other people but they don’t know what happened. I hope someone here Can help me. Thanks a lot.
by the way, I know the colors of the cables for pixhawk and receiver are not correct but are connected in the right position. In the video, you can see FlySky FS-i6X but is exactly the same problem with FS-i6. I tried with all the signal combinations but it din’t work.



video: https://drive.google.com/file/d/15aNEE9cJd7ZCGk4B7l0N_KxIRfGyO1rk/view?usp=drivesdk

First, make sure you have installed the latest stable firmware and updated MissionPlanner

You cant use PWM output mode at the receiver, that is for connecting several servos or ESCs directly to the receiver outputs.
While you are messing around with the radio, set a 3 position switch to channel 5 for flight modes, and in MissionPlanner set the positions to Stabilize, AltHold and Loiter.
Select PPM output, do the RC calibration in MissionPlanner, then do the semi-automatic ESC calibration
https://ardupilot.org/copter/docs/esc-calibration.html#semi-automatic-esc-by-esc-calibration

Next get your voltage monitoring working, and as accurate as possible. If you can get the current monitoring working too.

There’s a new screen in MissionPlanner that is probably not in all the YouTube videos - Initial Parameters
Go to the Initial Params screen, put in your prop size and bettery cell info, accept all changes it offers, plus the “Suggested” settings.

MissionPlanner motor test - use that next, and until you are sure everything is absolutely correct do not attempt to fly. Once motor test order is working: A = front right, B = back right, C = back left, D = front left
then you can attempt flying!

1 Like

Hello xfacta, thanks for reading and your help. I have done all the things you told me but I have the same problem, the ESC seems to be calibrated with the semiautomatic calibration (I followed the link you sent) but when I disconnect the battery and connect it again I move the throthle to the max and nothing happens. I tried with the throthle in reverse but is the same problem. Inclusive I changed between iBus-PPM and SBus-PPM (and I assigned Switch C as my channel 5 and I put the flight modes you told me) but don’t work. :sweat_smile:

If motor test works it will be fine.
The motors won’t work outside of motor test without passing all arming checks and arming via RC sticks.
Bench testing doesn’t give realistic results.
HINT don’t disable any arming checks

I think the problem is solved. I put my RC in PWM output iBus and it worked. After ESC’s calibration I pressed the channel 4 (with the joystick) to my right for some seconds and the motors started to spin. Nevertheless I couldn’t understand why Sbus PWM output didn’t work, but for future projects I would checked the protocols for these things. Thanks for everything.