My Pixhawk does not connect + Mission Planner failed to upload firmware

Hello Ardupilot community
My Pixhawk was working fine and Mission Planner was working fine too. I was able to install firmware without problems. I installed Arduplane (several times and I updated it), then I replaced it with Arducopter, and now I want to go back to Plan.

However, when I tried to change the firmware (from copter to plane again), it failed to upload, and I got the error: “Unable to upload firmware”. The process goes through “erase…” and finishes but, when it starts to “program…” it stops halfway and shows the error,
I tried putting the SD card in and tried to format it, the problem is still there
I unplugged the telemetry and the receiver (they were connected when the issue first appeared), the problem is still there
I tried to uninstall and re-install mission planner (still issue not solved).
I tried using a different USB port, the issue is still there
I tried with and without the SD card (no use)
Now, my Pixhawk is connected, but the main LED is not blinking, and the B/E led is flashing (Other LEDs are ok).
Can someone help?
PS: I am using Windows

Edit: The blinking LED is the FMU B/E, and PWR LED is fine, and so are all other LEDs
Edit 2: The buzzer does not make any sounds also

Use a shorter USB cable. And power the vehicle with a batery while programing.