My AT is not working

Hi, i installed Antenna tracker to Pixhawk, but servos not working.
What iam doing wrong?
Instructions :

After looking at your video, I saw two possible reasons.

  1. The safety switch had not been pressed.
  2. You do not have 5v power applied to the output ports to power the servos.

Try posting your questions to the developers thread below for a faster response.

figuring out the Antenna Tracker

Did you finally get the tracker working ? I had the same problem, and I did press the safety switch, also 5v to power the servos plugged to Pixhawk, but servos do not move. I have been spending over 1 year, but still could not get it work.


We haven’t done a release of the antenna tracker in over a year but I will put it on my to-do list to put some time into another release. The official stable version delivered by the MP should work though.


Thank you for your effort.
I have been very desperate for over a year to get anyone of the 3 tracker
configurations working, but without success. The 3 config are :–

  • AT Config 1 — Ground Station in the middle
  • AT Config 2 — Antenna Tracker in the middle
  • MP based GPS tracking

I now pick up this project again and focus on the AT Config 1 first, as
follows :–

I have a pair of telemetry radio linking my quad to GCS PC running MP. The
tracker is a Pixhack flashed with Antenna Tracker V1.0.0.

Referring to the video (the first one) under Antenna Tracker Home in, the brief instruction does not say how the GCS forwards the
spatial info to the tracker. I tried to connect the GCS PC with a USB cable
to the Pixhack tracker, but that does not make sense. I also tried to
connect the GCS PC to the Pixhack tracker using another telemetry radio
(same net ID as the first pair) connected to Pixhack tracker. Again, it did
not work, as expected, because (I think) the GCS can only establish link
either to the vehicle or to the Pixhack tracker, but not both at the same

The 2 servos connected to Pixhack tracker are powered by 5V. After I power
up the quad, with GPS locked, arm the quad on the bench, and increase
throttle (prop removed), both servos do not move.

Pls advise what I should do to forward the GCS spatial info to the tracker.
Not sure what the other guy who have been successful did, and which the
wiki does not mention.

Appreciate your help.


PS : I have posted the following 3 threads in the Antenna Tracker section
of the forum, heading as follows :–

  • ArduPilot Antenna Tracker
  • Mission Planner GPS-based tracker connection problem
  • AT “in the middle” Config 2 – Not working. Pls help.