Servers by jDrones

MWOSD firmware on a MavLink/minimOSD... NO DATA

I have a MavLinkOSD running MinimOSD Extra 2.4 connected to the Telem2 port on a Pixhawk running AC3.5.1.

I just got a new MavLinkOSD. I flashed it with MWOSD 1.7.4 firmware and the default MWOSD character set.

When I connect the new OSD to the Pixhawk and power up, the OSD boots, displays the opening screens, and then shifts to the HUD. I have artificial horizon, scroll bars, GPS icon, battery icon, call sign, and NO DATA flashing on and off…

I have tried the MAVLINK (APM) build and the PX4 build. I have tried setting Telem2 protocol to MAVLINK1 and MAVLINK2. Baud rate is 57600…

Any advice will be greatly appreciated.

RESOLVED…

The problem was with the firmware. I was using MWOSD 1.7.4 which includes a registration parameter that was not being set. I switched to MWOSD 1.8, registered, and now the OSD is getting data…

I also had an issue getting MWOSD 1.9.1.4 to work. My setup is reasonably simple and has a MicroMinim connected to a Pixhawk FCU. It was previously working with ExtraOSD, so I knew the hardware was good.

I tried flashing the MicroMinim with several different flavours of the firmware, but the OSD kept showing the ‘No Data’ warning.

The issue in my case was the SYSID_THISMAV value on the Pixhawk flight controller. The SYSID value was set to 2. Changing it to 1 fixed the issue.

Until the OSD and Pixhawk had communicated, the Mavlink tab in the MWOSD Configurator was inaccessible - meaning the SYSID value couldn’t be changed there.

To my surprise, the Mavlink tab became available in MWOSD Configurator after I changed the SYSID on the Pixhawk to 1 and I was able to change the value there and reset it to 2 on the Pixhawk (which is how I have it configured to differentiate between Pixhawk devices).

This may not be a common issue, but I thought I’d post it in case it helps someone.

Servers by jDrones