Multipoint Relay Setup with RFD868ux - GCS Connection Problem

I want to increase telemetry range and tried implementing a Multipoint Relay Setup using 3 units of RFD868ux by following the instructions given in this link. (Single network with Relay Node - 64kbps)
In the current setup, the GCS is connected to Node 2 RFD Modem , Relay unit to Node 1 and Aerial Vehicle to Node 3.
The problem I am facing is that the modems are binding with each other i.e Node 1 binds to Nodes 2 & 3 (confirmed by the all modems’ status LEDs indicating they are connected) but when trying to connect the GCS to Aerial Vehicle, it does not connect.
When troubleshooting to eliminate the possibility of RFD modem damage, I connected Node 1 to the GCS and Node 2 and 3 to different Aerial Vehicles (i.e Pixhawk Cubes). In this case, Mission Planner (GCS) is able to establish connection with both the Pixhawks.
If anybody has successfully implemented Multipoint Relay setup, please help

AVN Ravi

Hey Ravi, any update on this?
Been trying the same, and got the same result as you did.