Multiple SITL Instances Connected to Mission Planner

Hi everyone,

I’m doing a project where I would like to simulate two planes flying around each other and will need to see both at the same time.

I’ve got two instances of Mission Planner’s built in simulator running on two separate computers. Is it possible to connect both instances to a single Mission Planner such that I can see both on a single screen? Otherwise, is that another way to display two simulated planes at the same time?

Thanks in advance for any responses!

Four MP instances on a single laptop.

You can even have different voices for each. Four tlog’s are written.

With a single MP instance: connection lists.


Something like that?

Try the latest beta mp. The inbuilt simulation now allows swarm copter/rover/plane

1 Like

Mission Planner now allows for the use of swarm copters, rovers, and planes. However, if I want to create a plugin that changes the home position of the plane to the GPS position of the rover, I need to run both the rover SITL and the plane SITL simultaneously. Unfortunately, when I turn on the plane SITL, the rover SITL turns off.

firstly, I ran SITL via mission planner,

though, I wasn’t able to run it via mission planner, I tried CMD.

ArduRover.exe -S -I0 --model rover --defaults rover --console

after I type above command line, I typed below line

arduPlane.exe -S -I0 --model plane --defaults plane --console

and there was error :
The application was unable to start correctly(0xc000007b). Click OK to close application.

I attempted to follow the instructions provided on the following link, Setting up SITL on Windows — Dev documentation. However, I encountered an issue where turning on another SITL instance resulted in the existing instance connection block. I guess this is because both instances are sharing the same address (

Could anyone please advise me on how to change the address and successfully run two MAVProxy SITL instances at the same time?

I ran two mavproxy SITL instances, and result was same.

I tried to change the address with this command line, but result was same :

$ …/Tools/autotest/ --out udp: --map --console