MSP protocol support

current should work, is it working in Mission Planner? Did you properly setup a battery monitor?

Hi folks. I’m about to buy a Shark Byte system, but am concerned about OSD. I looked thru the thread and saw nary a mention of Shark Byte. I’d like to know if ardupilot will support OSD with the Fatshark Shark Byte system.


Hi Alex, sorry to bother you, but I can’t seem to enable the MSP support for Matek 3901-L0X lidar in Config after I flashed the copter to latest stable version. My FC is Kakute F7 Mini. I tried to follow your note about manually adding support back in hwdef.dat, but got lost in trying to compile. Is it possible that you can help to build the latest firmware with MSP support of Kakute F7 mini? Thank you very much.

stable does not support MSP, you need to go beta for copter or master for other vehicles

Hi, SharkByte should work fine with older firmware, latest firmware switched to canvas mode which ardupilot does not support yet, ask in the OSD channel on discord for people using it

I see. Thank you Alex.

Thanks very much Alex,

What’s your guess as to when Canvas mode will be supported on Ardupilot?

Also, I have just a wee bit of understanding about Discord…I have the app installed and running, but I’m not sure how to find the “OSD channel”. Any help appreciated.

Thanks again.

Hi, this is the OSD channel, there’s no estimate on canvas mode support.

Hi …i want to ask, what firmware you guys use to set up the MSP protocol in mission planner?. Copter 4.1.0 Beta?. Thanks for your help!

Hi, SharkByte should work fine with older firmware, latest firmware switched to canvas mode which ardupilot does not support yet, ask in the OSD channel on discord for people using it

Alex…I received my Sharkbyte and can not get an OSD working with Arducopter 4.x, even using an older SB firmware…you were saying SB should work fine with ardupilot with an older firmware…could you be more specific? Thanks so much.

Hi, you need ArduCopter 4.1.x or latest master

Alex…I loaded up 4.1.x on the Kakute F7. I’ve tried serial 4 and serial…still no OSD using Shark Byte.

Couple questions:

  1. What “serial option” should I be using? I’ve seen refences to 33 and 32. (and 115k baud?)

  2. And I’d like to confirm I should be using MAVLINK1 (or MAVLINK2?) as the “serial protocol”.

  3. I’m using the firmware installed at the factory on the Shark Byte (21.43.3C)…it’s old…I left it there as the only other firmware I see available is the latest, which is of course CANVAS, which of course will not work. So the question is, is there a certain version or range of versions of Shark Byte firmware that I’m suppose to be using?

Thanks again.


ah…KakuteF7 does not have MSP built as default, no flash space, you need a custom build!
Do you need plane or copter, I can build one for you

Wow Alex…that’s very generous. I’m flying a couple quadcopters.


here you go ArduCopter 4.1dev KakuteF7 custom build with MSP support

Thank you Alex! I’ll try it on Monday.

1 Like

OK…well…still no OSD.

I’d like to confirm that I can use serial/UART 1 (telem 1), 2 (telem 2), 4, etc (GPS is 3, SBUS is 6), as long as I have the “serial protocol” set to Mavlink1 (should I use Mavlink2?), AND I have “serial option” set to 33 (or is it 32?).


Hi, a little confusion :slight_smile:
You need to set SERIAL_PROTOCOL=33, SERIAL_OPTIONS=0, you do not want Mavlink, you want MSP!

That did it Alex. Thank you very much. Truly, much appreciated.


1 Like

Hi all,
I’ve just build a quadcopter with a KAKUTE F7 1.5. Everything is working fine along with the crossfire but I am still having issues with the matek 3901 optical flow.
I connected it to uart2, tried uart4 also and configured it as per Matek Website. The Opt flow sensor has a fixed red light and a flqshing blue light which seems ok.
I have 0 on all readouts on the status page.
Tried with stable and latest versions but no help.
Am I missing something?
Thank you.