MP under Parallels (on Mac)

I run MP on Windows 7, under Parallels 9 (and earlier V8) running on a MacBook.

Upon initial Mavlink connection it looks as if I get a huge number of interrupts. Some data (parameters) are loaded / reloaded, GPS and other flight params are displayed correctly but while the connection is being established, finally a timeout occurs and the link fails.

On my Netbook running Windows 7 natively, everything works fine.

Besides MP I run a couple of other Windows mission control apps on my MacBook without any problem.
The USB device (Mavlink) is detected and assigned to Windows properly.

Does anyone know what the problem might be?

Does your problem solve ?
I am using Parallels 8 on Mac Book Air , may be can help you to compare the setting

My problem hasn’t been solved yet, unfortunately. Thanks a lot for the support.

Trying to establish a Mavlink connection, everything starts well, a first set of “parameters” are loaded and even displayed successfully (I guess). Then after a short interrupt, parameters are reloaded (that’s what the popup dialog says). After a while of recurring loads/reloads the connection process finally fails.

Under lab conditions I was able to properly communicate. That was under Parallels 8. However, every now and then the same interrupt / cannot-connect patterns occurred already.

I could imagine that the virtual COM-port driver has some timing problems, running under Parallels. However, trying to upgrade the driver claims that it is already up-to-date.

Following are my setting

MacBook Air
MP = 1.2.87
COM port showing – Arduino Mega 2560 (COM5)

I have only one incident where I keep getting disconnect , swap to another USB port work fine .

Hope this may help


sounds like a power issue

Hi, i am about to buy the macbook air m1 but i want to make sure it perfecly works (with paralleles) for MP
So which macbook air do you have and does it work fine with mission planner ?
( No mavlink drivers issue or anything like that ?)
Thank you