MP not saving Joystick settings

Hi Everyone,

I have just upgraded my MP and now when I set all of the channel controls for my Joystick I hit save. If I close the joystick window and then open it again all of my settings are back at the default settings.

Can anyone tell me what I might be doing wrong? The last time I used my Joystick I set it up and then every time I used it my settings were set?

I’m using the latest version of MP, Pixhawk, Rover firmware (latest), thrustmaster T Flight Stick x.



Ok, so today I unloaded and reloaded MP and reinstalled to drivers for the Joystick. Again MP is not saving the joystick settings and when I hit “enable” the output bars freeze and the servos don’t respond. Everything functions correctly with the RC tx/rx.

So that didn’t work so I tried the MP beta version and again the same results.

I have a good telemetry connection 96%, 3DR radios, running windows 10, all drivers are up to date through the new install of MP.

Have I missed a setting? This all worked fine with APM 2.x



2016-11-13 20-03-55.tlog (2.5 MB)
2016-11-13 20-47-33.tlog (269.7 KB)

I am using Pixhawk Rover with latest build ( v3.0.1), MP latest build (1.3.41 build 1.1.6110.31287). I can connect the MP to the Pixhawk, telemetry is accurate and functions, I can ARM and DISARM through MP, I can open the Joystick settings window and change the settings, mapping the rudder and throttle, also mapping/setting the mode change buttons. As soon as I hit enable the output bars freeze and the joystick does not engage with the boat. Once I disable the Joystick the output bars become responsive to the Joystick.

The other point to note is that MP does not save the joystick settings. If I close the joystick window and reopen or close MP and reboot MP all of the joystick settings are lost.

Is anyone else using a Joystick or game pad?



Ok, I found one of my laptops with an older build of MP (1.3.39 BUILD 1.1.6038.12291) fired it up and connected to my boat (pixhawk, rover 3.0.1, over 3DR radios), all worked fantastically, my settings were saved and everything functioned as expected. When I hit enable, joystick becomes live and the boat responds - throttle, steering, mode settings etc.

When I switch the joystick and radio back to the new MP build on the other laptop settings are not saved and the joystick freezes if I try and enable.

Is anyone using a joystick with the new MP build?

Have I missed a setting or is this a MP issue?

Thanks in advance,


please update to the latest beta MP

got help > update beta

Hi Michael,

Thanks for that I didn’t get a chance to test it yesterday, but I have just finished bench testing and all is looking back to normal.

I will endeavour to get out on the water in the next couple of days and do some live testing, but from the bench testing I don’t see there being any problem.

Thanks again for your great work.



I can confirm that with a fresh install of MP (1.3.41), the joystick settings are not being saved. Even after upgrade to Beta (, it doesn’t work.

I took all the joystick files from an old install, copied them to the MP directory and voila, it worked. Definitely a bug.

Also in this kind of situation I would suggest to take a look at Windows system. I had problem with saving settings for joystick. I copied folder of MP from my working laptop to desktop PC. I took me hour to understand that I didnt have right to write in “Program Files” folder. After moving MP folder to root, everything was fine when I launch MP directly from .exe; but same problem with saving settings when I tried to launch it from shortcut, where I forgot to change working directory in its settings. Probably good workaround would be to make somekind of check if file of the settings was wrote successfully or not.

For me I just updated MP to the Beta as Michael said and it has worked flawlessly since.

I’ve downloaded version and noticed a bug: joysticks settings are not saved when selecting ‘Auto Detect’ Button though they are well saved using the Controller Axis list.

Also, Pitch and Throttle are inverted and are not corresponding to the mapping made in the RCMAP parameters.

1 Like

This info about the Auto Detect helped a lot, thanks.

Hi, I am using version 1.3.45, and upgraded to beta 1.3.45 v2 and have the exact same problem as described by @Lat_Long

Will try to install an old version and save the joystick file to the new directory