MP Beta v1.3.39.3 Survey Grid Camera bug(?)

Apparently the cameras cannot be loaded nor saved inside the Survey(grid) module on

After upgrading from 1.3.39 only one camera was in the camera drop-down on the simple menu (I think it was a Canon S110). Everything seemed ok after re-entering and saving the specs for a new camera in the “Camera Config” tab but after restarting MP the specs for the camera revert to the defaults.

This is under Win10 Pro 64-bit run as admin.

depending on how new the beta is, the config files have moved to "my documents > mission planner"
if you give me the details on your camera I can just add it permanently.

Ok… I tried moving the cameras.xml to the new location with no change. Adding the camera may not be a perfect solution because NONE of the cameras are showing up on the list. The name of the last camera I entered shows up, but the parameters change back to something else. This is on version Build 1.1.6099.16298

Here’s the empty camera drop-down

…and the defaults it reverts to.

added, thanks. will be in the next MP versions

oh btw, 1.3.40 fix’s this bug. it was a file path issue.

I have this issue in the notebook but not in pc 64bit , the two running W7, I uninstalled and re installed but same issue, Installed beta 3.4|.1.3 and the same, another issues that I have, when I check, some options for ex footprint, automatically unzoomed the map, other,: in stats: Pictures n° is always in 0, Any idea? thank´s

please post a screenshot or similar, as I don’t have a lot to go by

Here no cameras to choose and look that no pictures number
when I choose footprint this happen with zoom

And this the camera config page looks

Thank’s Michael for take a look.

I found some different files in documents -MPlanner in the working and no working pc so I copy from one to the other all the files and now picture number work’s, in camera choice says “Default” and nothing else and unzoom still happens when I check -unchek display options.
Files are config-param meta data-stats and tree files were missing at the notebook (71 files vs 74 in pc) but at pc I have vers and at the ntbk now but 4.0 don’t work too.
(Another thing, the choice enable Angel airspace appears again and now I choose NO, first time I choose YES.)

Solved: different config in my ntbk. than PC