Servers by jDrones

MP 1.3.41 Connection Issues with Serial and RFD900+


(Nick) #1

I just wiped out my surface pro 3 tablet which I have been using for the past year with arducopter and mission planner. Its been a great tool if anyone is thinking about one. Since I wiped it out and reinstalled windows 10 with the image provided by windows I had to reinstall the basic stuff. I have been having issues with Mission planner connection on com4 to an RFD900+ with the included USB-FTDI cable.I can get a connection most of the time and once the parameters are downloaded it disconnects and I hear windows make the USB disconnect and connect sound. It will just do this over and over. I have been trying different FTDI drivers but with no luck. I also have qgroundcontrol that I dont really use but decided to give it a try. It connects fine and I left it for an hour and it maintained connection. I uninstalled all FTDI drivers, mission planner and 3DR drivers and rebooted twice. I then installed the previous version of mission planner 1.3.9 and noticed that it came with FTDI drivers and after a restart it connected fine and seemed to hold the connection. I would stick with this version but I am running a pixhawk 2.1 with 3.4.3 and it doesnt seem to be getting all the parameters. I also tried to install 1.3.41 after 1.3.9 but the issue came back. Any suggestions?


(pmshop) #2

1.3.41 has had some Windows 10 issues.
Try running Mission Planner in Windows 8.1 Compatability Mode.
This has cleared other issues (overlapping frames & repeated text/ screen not refreshing) - it may help with your issue.


(Nick) #3

Thanks for the tip. I will give it a try and test.


(Nick) #4

Tried different compatibility modes and installing latest mission planner beta. I use windows 10 on my desktop and it doesnt have any issues. I am going to try reinstalling windows 10 again and see if that helps

edit: no matter what i did i could not get mp 1.3.41 to work. I tried installing the official surface pro 3 windows image and the a regular oem windows 10 image. FTDI just keeps disconnecting. I also notices that on 1.3.41 when i told my pixhawk 2.1 to reboot it made the pixhawk 2.1 freeze and the lights were orange. Trying 1.3.39 now


(Juri) #5

Your problem is most likely with unoriginal FTDI-device. Use, for example, the original “Crius”.


(Nick) #6

what is “Crius”. The same FTDI driver works on windows 10 on my desktop with the latest mission planner. Is there another source of FTDI drivers? I used the FTDI usb viewer tool and it says the idVendor is Futur Technology Devices Int.
amd the idProduct is FT232R USB UART. Seems like its is an FTDI device?


(Juri) #7

Just the same Pixhawk problem I had, with a fake chip … You have a FTDI-chip original.


(pmshop) #8

The Windows 10 issues I speak of have been on laptops.
Something about either mobile chipsets or graphics drivers in my case.
The issue has not been seen on desktops.

But It may be a chipset issue causing that FTDI recognition.


(skyscraper) #9

There are 2 voltage levels for FTDI. Some are 3V and some ar 5V and some are switchable. Using a 5V FTDI on a 3.3V system can cause random issues, since it is not quite the right voltage level. That said, I dont know what voltage levels Pixhawk uses, but I think APM is 5V. Same issue in opposite direction if you use a 3.3V FTDI there!


(Nick) #10

Any ideas on why it would happen now? I have been using my surface pro 3 with my pixhawk V1 and the same cable/RFD900+ modem for months now with no issues. My work is buying my UAV setup so all I did was reinstall windows 10 originally so I didn’t have any personal data on it. I have tried using windows 8.1 as well. The issue is definitely mission planner. Both qgroundcontrol and UGCS will hold connection. I let them both run for an hour with no problems


(Michael Oborne) #11

if windows is ding/donging then the issue with with usb power. or its a bad ftdi chipset. as the device is unplugging and plugging itself. i highly doubt a mission planner issue in this context.


(skyscraper) #12

In that case,could the problem have to do with the power required by the RFD900+ . Says here it can take (EDIT 800 mA). which could be out of spec for powering from USB at full power? Maybe try powering the AP via a battery?


(Nick) #13

I tried to turn down the power output on the ground side radio but it never made a difference. I dont think it was a power issue as I have been using this setup for a year now with now issues and have always had the ground radio power on the high side… 28 on the RFD modem tools applications. The issue also does not happen with qgroundcontrol. I noticed last night that an update was available (1.3.42 i think?) so I gave it a shot. This seems to have fixed the connection issue as well as the small text/scaling issues I was having on my surface pro 3. I used mission planner for a few hours today with no problems so what ever changed it, if anything, it is working now! @Michael_Oborne , thanks for all your work in mission planner. It has been a great tool and also you support on these forums.

Thanks for all the input everyone!


(Alexander Perez) #14

Has any one been experiencing any more connection issues with RFD900+ on the latest Mission Planner 1.3.48.3 build 1.1.6405.28982? I’ve been using ArduPlane 3.7.1 and 3.8 beta 6 without an issue. I noticed after installing the latest build of Mission Planner, I now can no longer connect. I appreciate anyone’s feedback.


(pmshop) #15

Try another revision of MP - ver 1.3.49 is out now as of the 20th


(Alexander Perez) #16

Thank you @pmshop for your response. I will try it out.


(Alexander Perez) #17

Just an update, I just updated mission planner back to 3.8 beta 6. I’m using v1.9 fw for RDF900. Unfortunately no connection still. I’ll try to upgrade the FW and see if that works.