Servers by jDrones

MP 1.3.38 build 1.1.5990.37365. ESC Calibration not working

I’m running MP 1.3.38 build 1.1.5990.37365. I think it’s the latest beta build. I hadn’t been able to get ESC calibration to work under any circumstances until yesterday when I again tried the MP version on 3.4RC1 with the PWM type=0. When I changed the type to 2, no luck, so for now I’ll just wait for the Oneshot125 calibration to get fixed.

I actually had it in the air without running the calibration since I have XM20As with Blheli fw and could manually set the ESCs.

You can check the BLHeli version. I’ve calibrated 4 XRotor 20A on BLHeli 14.6 with 3.4RC1 with OneShot125. Also check if the programming by TX is enabled

Here are the parms I saved when I last updated them. I do have Program by TX set and was able to calibrate once in PWM mode but not Oneshot125.

Did you get it to work using the MP version initiated calibration or the Throttle high, battery plug, unplug, plug method?

kind of :slight_smile:

So first. I use the new parameters MOT_PWM_MAX/MIN and set’em to my desired value, in this case 2000/1000

Then I set this parameter to 1 and reboot the PH with throttle high on the radio, press the safety button and wait for the beeping of the ESC’s and then throttle low, more beeping from the ESC’s

to end up. I power cycle the PH (plug off/plug on).

The previous message with the BLHeli screenshot was the result of one of my ESC’s. Note that the low pwm value is not 1000 as expected, but I redid this several times and it was always the same value on each ESC, but slightly different values (1012/1014/1016) between different ESC. Just in case, I attached a logic analyser to make sure that the values were correctly being sent by the PH and they were, so it might be some weird clock thing from the ESC’s.

Ah, I hadn’t tried setting ESC_CALIBRATION to force it into calibration mode. I think I’m getting it into calibration mode though because I get the long low tone. I just don’t get any tones from the ESCs when I’m set to use Oneshot125.

I’ll give your process a try and see what happens.

Thanks

Oh, btw

don’t loose much effort on that. You can calibrate the ESC’s on normal PWM and then switch back to OneShot125 and it works perfectly. Also did that :slight_smile:

Note that I’m using the latest BLHeli, so would be also something to check.

Interesting, I thought i saw there you needed to re-calibrate when switching to Oneshot125. I’ll try it and see what happens. I’ll also look at upgrading the ESC firmware as well.

Thanks

I tested all the possible combos :slight_smile: , PWM, OneShot and Oneshot125, and even no calibration, i.e. setting a range on the ESC and on the PH. Unfortunately we can’t be sure of the PWM values that the ESC interprets.

I connected the logic analyser to be sure I was “injecting” correct PWM values, but that small clock drift on the ESC’s defeats the effort…

I found it seems to work fine by just setting the PWM values, although not the most convenient method. What I don’t know is if/how they can be manually set for Oneshot125. I assume that calibration is necessary since the timing is quite different. I only have a vague understanding of it though. I’m a bit curious about what the FC sends to the ESCs when it calibrates in Oneshot125 mode.

ESC calibration has only just been fixed so pre-3.4rc1 it didn’t work for many people including myself. But I managed to calibrate yesterday on 3.4rc1 using oneshot125 mode. Plugin pixhawk power with tx throttle fully up, wait a few seconds, unplug power. Replug power with tx throttle still fully up, then hold the safety button down until the ESCs start beeping, then lower the throttle. This is all as per the official docs:
http://ardupilot.org/copter/docs/esc-calibration.html
I also remember someone (Tridge?) saying calibration should be redone for each pwm type.
This was with T-motor 15a (hobbywing rebranded), not blheli type esc.
Slightly different ESC values are I believe why you do the esc calibration, to match to the pwm oscillator differences between individual ESCs.

Oh no, I take that back, it wasn’t successful… I followed the all-in-one calibration procedure as normal and when plugging the power back in for the second time (which should be in calibration mode) and pressing the safety button the ESCs started beeping, then stopped beeping when throttle pulled low and the motors throttled up with throttle, as per normal calibration. But values weren’t changed and it turns out the ESC beeping wasn’t program mode but trouble mode when they weren’t getting any signal from the FC.

:frowning:

nothing is working…i just can’t calibrate my Plush 40A blheli ESC…

How is your mot_pwm_type?

I can only calibrate with mot_pwm_type 0 or 1. Please read First flight and autotune - impressions and small issues

.i made multiple ESC calibration with all methods and every time during calibration ESC responded exactly as they should but as soon as i arm my Y6 arms(particularly back one)start to vibrate and oscillate.mot_pwm_type 0 (normal)…and throttle response is not the same any more…not linear at all…i even put mot_thrst_expo to 0 (default was 0.65 i really don’t remember that i touch that ever before)…

Also from some strange reason i can’t disable arming check so i no GPS reception no testing…

Emin,
You should be able to arm in non-GPS flight modes (Stabilize, AltHold, Acro) even without a GPS unless the circular or polygon fence is enabled. If the circular and/or polygon fence is enabled then the flight controller need to know it’s position to be sure that it knows whether it’s within the fence or not.

We’ve got a fix for the oneshot calibration coming in -rc3 within days.

AAAA…thank you Randy,fence was enabled…

Servers by jDrones