Servers by jDrones

Mototrs wont connect

Newbie
Have not been able to make motors run. Other calibrations and adjustments OK
Equipment:
Holybro X500 frame
Pixhawk 4 with pm07 power unit
4 Lumineer 30 amp 32 bit opto ESC B+& Bat Gnd &Signal connected to pm07 but no Signal gnd
2216 880kv T motors
Realize signal should have gnd connected but should not keep the motors from running
Need Help any suggestions

Clearly your “Other calibrations and adjustments” are not ok. So you need to have a detailed description of what you have done for anyone to help you with your problem. The logs are your friend and you need to turn them on to help isolate your problem. There are also many failsafes that will prevent the motors from turning if all the “Other calibrations and adjustments” are not correct.

Do they run using Motor Test in Mission Planner?

Started out in QGround Control. Eliminated all errors that voice provides and in print out logs during start up. No errors as regards ESC. Used CHIBIOS?? firmware and default settings. The ESC not providing any power. I soldered all connections. Conceivably could have a soldering problem but not effecting all motors. It very easily could be an arming problem but software does not indicate, and I couldnt find. Same result, as expected, in Mission Planner, motors would not run. I have to disassemble platform and components and start all over. Before disassembly maybe I should flash it back to Pixhawk4 software and start again???

The logs will tell you what the reason for not arming. You need to turn on the parameter that allows arming before take-off.

After much aggravation I got motors running in MP and with transmitter. I am still receiving Bad AHRS and after checking many comments and solutions on the netI have not been able to duplicate their screen solutions. Is there an up-to-date solution so I can arm. Although it does not effect arming with transmitter

Hi Robert
I have the exactly same problem: The entire frame X500 built and all calibrations are ok. I can arm and activate the saftey-switch.
But the props / motors never start to work.

Somehow I am lost. I don’t know, if the problem is caused by the software (QGrundControl) or by the hardware (wiring).

Do you have a good description of the X500 and the wiring? How did you solve the problem?

Looking forward to any hints,
Yvo

Do the motors work from Mission Planner’s Motor Test?

Good point. No. I can’t even test it. Everything is grayed out @ optional hardware - motor test.

Then you need to update MP 1st. Go to the Help Screen press the “Check for Beta Updates” button.

Well, update done as you mentioned. But still all buttons grayed out.

The ESC-Calibration tells me, that I am not using AC3.3+.

Till now I did all the setup and the calibration by using the QGroundControl as mentioned by Holybro.

Are you even using Arducopter or the PX4 Flight stack? QGC has a Motor Test function also, use that if you are using PX4.

Mh, I am pretty much a dummy. I tried the motor-test in QCC as well. But I receive an error message that the motor test command is not supported.
I am using a Pixhawk 4 and I did a firmware-update by using QCC.

I update the firmware again and I am able to start the motor-test in QCC. But the motors are not spinning at all.
Also the motor-test in MP is available now. But the motors are not spinning as well.

In both cases, it arms and disarms a second later.

Any idea?

Have you tried increasing the time (sec)?

When you did the firmware update did you select PX4 or Ardupilot? If the later you are in the wrong place. The PX4 Flight Stack has it’s own forum.

Hi Hari

Yes, I tried. But no effect. I just realized, that I am getting always a “Prearm: Throttle below failsafe” error-message. But I was not successfully in finding any hints regarding this error.

Any hints?

Looking forward to any suggestions.

Cheers,
Yvo

https://ardupilot.org/copter/docs/radio-failsafe.html

Servers by jDrones