Motors won't spool up when armed with props

I am currently reviewing the .bin file to see what I could have possibly missed with this build.

Here is the issue that I am dealing with…

When I arm the quadcopter without the props the motors spin up with no issue.
When I add the props they will arm and spin but they won’t spool up, even with full stick input.

Possibly a vibration issue?

Hardware is the cube orange +
21in 3 blade props
1000mm quad frame.

Yes I went through the configurator meticulously, this was supposed to be my first config flight

Large quad param1.param (20.9 KB)

Post a .zip file with the .json and .param files created by the configurator

I believe this is it.

Let me know if not. I wasn’t totally sure how to get those files besides going to the folder that they are stored in.

Yes, you can do that.

Or when you finish the configurator by uploading the last file it also automatically creates a .zip file for this very purpose.

@Janno can you take a look at the files? I’m not at the office right now.

I really appreciate you looking into this. The thing that’s most confusing here is the motor spooling up fine without the props but soon as I attach the props they won’t go past mid throttle

“Meticulously” includes changing the “reason changed” fields :wink:

Let’s go through the files one by one:
(Whenever I compare to a template, it is the “Taycan 4.5.3” template)

  • component editor: mostly well done, but why are ESC → FC Connection Type and Protocol set to “SERIAL1” and “Brushed” respectively? Those should be “Main Out” and “DShot600” when you are using a BLHeli_32 ESC.
  • 02_imu_temp_cal_setup: INS_TCAL3_ENABLE and INS_TCAL3_TMAX are missing, you should have added those. “reason changed” not edited.
  • 03_imu_temp_cal_results: here IMU3 values are included :+1:t2:
  • 04_board: identical to template, ok for this step.
  • 05_remote controller: identical to template, except for the protocol (which is changed automatically by component editor). “reason changed” not edited.
  • 06_telemetry: identical to template, except MAVLink protocol missing. “reason changed” not edited.
  • 07_esc: identical to template, except for stuff set by component editor (# of poles, PWM type) and telemetry, which is wrong (BLHeli_32 v32.9 doesn’t support EDT). “reason changed” not edited.
  • 08_bat_mon: identical to template, except for stuff set by component editor. “reason changed” not edited.
  • 09_bat_mon2: identical to template, except capacity (which is also wrong (10000maH instead of 20000mAh)) and BATT2_VOLT_MULT, which I can’t check. “reason changed” not edited.
  • 10_gnss: identical to template, despite having the gnss connected to SERIAL2 (according to component editor). “reason changed” not edited.
  • 11_init_atc: done automatic, looks good.
  • 12_mp_setup: why are flight modes 1 to 5 loiter and flight mode 6 is PosHold? You need at least 1 flight mode that is stabilize and 1 that is AltHold. Furthermore you will need Auto for MagFit and AutoTune for AutoTune. PosHold should not be used at all.
  • 13_general: identical to template, ok for this step.“reason changed” not edited.
  • 14_logging: identical to template, ok for this step. “reason changed” not edited.
  • 15_motor: identical to template, except MOT_SPIN_MIN. Very bad! If you do not have a thrust test stand, these parameters should be removed or at least not written to the FC (which you did according to your param file from the first post). “reason changed” not edited.
  • 16_pid_adjust: identical to template, very bad! The template is for a small 3" drone, yours is a lot larger and need very different PIDs! “reason changed” not edited.
  • 17_remote_id: identical to template, ok for this step.
  • 18_notch_setup: values look good. “reason changed” not edited.

stopped there, because now comes the first test flight (that didn’t work).

1 Like

Post a log file of the test that didn’t work, maybe we’ll find something there.

Is there anything that you see that would cause the issue that I reported?

What ESCs do you have?

Turn off Low RPM PowerProtect in the BLHELI_32 settings

I will try that tomorrow and report back, thanks!

This is a big craft.
Big vehicles need some kind of certification in most countries.
Can you get a certification on your country without presenting a detailed plan on how you configured the open source software that is responsible for flight stability?
Can you change parameters without explaining why and still get a permit to fly?

that fixed it thanks.

Please answer my questions.

I don’t have an answer for this yet, I will have to research.

Post a .zip file with the the improved .json and .param files.

You’re likely to hurt someone. I suggest tabling this project for a bit and learning the basics with a smaller, less dangerous vehicle. Come back to this one when you have enough knowledge to configure and fly the smaller one safely.


Where would I look in the log file to see if and why a motor would stall in the air, and how could I know if it was a desync?

Before looking at any logs, post the files I asked you to post.