Motors wont spin with dshot protocol


I have a setup with T motor F45A ESC. With MOT_PWM_TYPE set to Dshot and servo outputs set to AUX ports and safety switch disabled, the motors wont spin. When changed to PWM, the motors spin. ESCs are calibrated and motor test works fine.
But when trying to fly, the copter wont takeoff even though max throttle is given. They just spin at low RPM.

When check the ESC settings, 3 ESCs have input protocol Unknown. Could this be an ESC issue? How do I set the ESC protocol to Dshot in BlHelisuite?


Post your parameters - what flight controller?

I am using Pixhawk Cube Orange. T motor antigravity 4004 300KV motors.
Parameter.param (17.4 KB)

Pretty sure you have to use SERVO_BLH_OTYPE/MASK rather than MOT_PWM_TYPE on boards with IOMCU

And turn off Low RPM Power Protect

It works now with dshot protocol. But the problem with the motors slowing down after few seconds still persists. I turned off Low RPM Power Protect, also tested this with the ESC directly connected to the receiver channel 3. Could this a motor timing settings issue?