Motors will not Arm,

Hello All

I am new to the forum and have been flying and building quads of all shapes and sizes for the past 2 years,

I am trying to install a Pixhawk on my TBS disco
Tiger 2216 800kv and ztw 40Amp escs

I have done all calibrations including ESC.

But when arming press safety, it goes red then bottom right on tx i get nothing.

I can test motors and they work fine in setup, i do need to raise the number to 8- 9 % to get motors to spin.

So i am confident all wiring is correct.

When i Cal ESC i am able to throttle the motors, so happy all is connected here again. I just can not get the thing to spin once armed.

I have read many threads, and posts, tried changing some parameters but nothing.

Would really appreciate the help…



Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Thanks I sorted it out

When I went to extract and send the log file I noticed messages stated rc not calibrated.

It looks like once you change the parameters you need to re run the cal process

Once done all worked well…

Now just as I got ready for test hover I managed to nock the button safety switch and break the red and black wires off the button

Does any one have a pic or a pin out so I can re solder

My yellow is still in place


Sent from my iPhone using Tapatalk


Same thing happened to me. I not find the photos I took when I broke it but…

Here’s the wiring diagram