Servers by jDrones

Motors warm in Pixracer


(Pablo Talavan) #1

Hi everybody,

I’m a newbie here, but I keep in building drones since 3 years ago, I begin with an APM in a fpv racing drone and 1 year ago I jumped to the pixracer and another fpv racing drone.

Actually I solved many problems with the quad using leonardthall recomendations and others mates recomendations, and all it works well, but actually I only have a problem, my motors are hot each time I fly the quad. I tried dropping down the parameters of autotune pid (included d term) to get more softly in the quad, but all it the same, motors hot.

I reviewed my logs and parameters and I think have little bit noise in the gyro, a little bit in the y axis in the y axis, but I dont know if this levels are make my motors hot. For me I think the output graphics in the pixracer is a little bit stranger compared with the other logs mates, I dont know if this is normal. Anybody can I help me, because I fell lost with this issue. I attached my last log in my room hovering and my actually parameters file.

Too I put my quad configuration:
Frame: Outlaw hobbyking 270mm
Motors: Emax LS2207 1900kv
ESC: Racerstar RS20A V2
FC: Pixracer 3.5.7
Receiver: Frsky X4R sbus
GPS: Ublox M8N mini

PD: Thanks for your time and work hard, I’m a big fan of this project, I love it. Sorry for my English.

Hovering Room.zip (513.9 KB)


(llamatrails) #2

Probably need to change the esc motor timing parameter. This will be in the esc itself, not the Pixracer or Arducopter software.


(Pablo Talavan) #3

I tried it and the motors continued hot. I used medium and hight timing and anything changed. I dont know to do now
Thanks for your reply


(John L. Rodgers) #4

What is your prop size and pitch, also your lipo size.
This is a major heat factor.
John


(Pablo Talavan) #5

Sorry I forget put in the description.

I usually use 6x3 props and 4s battery

I’ve flew ten minutes ago with a very very low pid, and the motors are hot.

I’ve tried it with 2 firmwares, arducopter and px4, and it’s the same in all firmwares, motors hot.

I’ve tried put pwm type in normal mode and the esc calibration in bl suite and the same values in arducopter, and the same results.

I think my pixracer is a little bit damage