Motors only work at ~50% with remote, but 100% with MP-test

Hi! Newbie here, please bear with me.

I have built a F550 hexacopter with Ardupilot and Ublox GPS. I fly with a 5000mah 30C battery.

To cut things short, here’s my problem:

First time I tried to fly it outdoors the darn thing doesn’t even budge from the ground. My remote (a Devo7) says that I have throttle 50% and the hexacopter just wobbles slightly. If I increase throttle it looks/sounds like the motors throttle DOWN instead of giving more juice.

I tried this for 20 minutes and one time it almost tipped over (the two front motors giving a little bit more power then the rest) but this was solved (I think) with a all-at-once ESC-calibration.

But still, the darn thing won’t move. I try holding it above my head and give it 100% throttle and it feels like it pulls slightly backwards, but still no lift.

I hook it up to MissionPlanner and go into “motor test”, I put 50% and 2 seconds test and press “test all motors” and the freaking thing jumps up from the ground and flies two meters away - horizontally.

Yeah, I’m stupid to leave the propellers on while testing in MP, I know.

Sitting at home at my desk and trying the thing (without propellers on) I notice the following:

When my remote gives 100% throttle, the motors spin at a speed that is much much slower than when MissionPlanners tests the motors at 100%. Going by the sound of the motors, remote throttle 100% equals about 50-60% MissionPlanner motor test throttle.

THR_MAX is set at 1000 and I can’t find any other thing to change.

Please… anyone? My already gray hair is starting to get white.

(Mission Planner 1.3.38)

Have you gone through the RC calibration? It sounds like your initial setup wasn’t done. Do you have a log from your failed flight?

Remote/Transmitter-calibration is done without change in performance. I will see if MP created any log from the failed starts and post them here later tonight.

What parts of initial setup affects the motor effect?

What version software are you running? Is this a Pixhawk or APM copter? As far as I can see, THR_MAX hasn’t been used in a number of changes… I’m thinking that something may have been set with the current limiting feature or something similar. What mode are you trying to takeoff in?

I have an APM 2.5. According to MissionPlanner it is the latest version.
MP is 1.3.38 build 1.1.5983.12141 (if that matters) :slight_smile:

I try to take off in stabilize mode. I once tried putting it in hold position while running the motors at “full” speed (50%) and it just started tilting.

I can’t seem to find any settings that has anything to do with throttle or max throttle so I’m stumped. At first I thought it might be the battery that didn’t give enough juice, but 30C should be enought, right? And while testing through MP it can run 100% in at least one minute without problem - it’s just the throttle from the remote that seems strangled.

The remote is configured, and I have made an “all-at-once ESC-calibration” afterwards, without change.

I may just be stupid right now, but I can’t find any log from my flight attempts. How are they supposed to be accessable? (I’m under the impression that flight logs are created automatically).



I got it to fly. And crash.

Anyone good at reading logs that might explain what went wrong? (See new topic here in that case).

And thank you for all the help Netphreak, seems like the RC calibration was in the fault. Redid it two times AND made new ESC-calibrations afterwards and after the second time the speed was ok.