Servers by jDrones

Motors jumping up too fast in stabilize mode


(Christoph Michaelis) #1

Hello to all …
Question from a newbie :wink:
I have configured a big octo x8 … running up in stabilize mode makes the whole rig oscillate “a little ;-)” because motor rpm is jumping up too quickly … Hover throttle is set to learn and save … spooling up in althold or poshold is easy … will anyone explain how I may set the hover throttle also for stab mode correctly as I don’t quite get it from the ardu recommendations … I attached a log from my latest test hover (in poshold) on rc11 … Is also anybody willing to have a look at vibes please … are they within limits ?

The rig is foxtech devourer 130 with KDE 5215, 18" props, Herkules III esc board, 2 x 12.000 mAh SLS, no payload, reacting fine and crisp in the air …

Thank You all in advance.

Hope it works this way.


(Mike Boland) #2

Without a log file anyone would only be guessing.

Can you please post a log file with any support requests.


(Christoph Michaelis) #3

I uploaded but it didn’t work … Second attemp also failed … Did I do something wrong ? Used the upload button within posting box ?!


(Christoph Michaelis) #4

Shared a dropbox link … Upload didn’t work again.


(Mike Boland) #5

Your files can’t be bigger than 4.5Mb.
Maybe you should have tried zipping it first.

The RCout does not seem to be increasing excessively

But your vibrations are bad and is what is probably causing the issues you are seeing.
These need to be sorted.


(Mike Boland) #6

Tried to upload a pic of the vibrations but the new server seems to be gagging.

Just graph the ACC values for x, y and z and you will see what I mean.


(Christoph Michaelis) #7

Thank You so far … I thought vibes within a range of 10 were okay ?! Thought I read that somewhere …
And that’s what I saw when graphing the vibes with mission planner … What do You use for graphing ?

And the agressive motors didn’t occur during this flight … Just wanted to know if anybody could read out which hover throttle in/out I have for now and which settings would be needed to have a softer transition between idle and flying … I hope I explained it properly … ?


(Mike Boland) #8

I don 't fully agree with the VIBES values all the time and generally look at the IMU data to see what the sensors are seeing.
I use APM Planner 2 for graphing as it has some good features and follows the easy to use Mac interface.

So this is the RCin-RCout graph


(rmackay9) #9

I had a quick look and the vibe levels are pretty low actually - way down at only 7m/s/s which is about half what my IRIS has. By the way, we have a VIBE dataflash message which is easier and better than looking at the accelerometer values directly. http://ardupilot.org/copter/docs/common-measuring-vibration.html

I actually don’t see anything wrong in the logs. My guess is that you may want to lower the MOT_SPIN_ARM and MOT_SPIN_MIN parameters. It’s discussed on this wiki page: http://ardupilot.org/copter/docs/set-motor-range.html

Thanks for using ardupilot!