Motors Disarm When I Try to Lift Off After Arming

Hi, my name is Ian Hall. I have looked all over the forums and the rest of the Internet and YouTube. So here’s the problem:

I have my QAV400 set up with the APM 2.6. I have done the radio, accelerometer, and ESC calibrations. I am set up in the stabilize flight mode. When I try to arm the motors, they blip for a split second and stop firing, or maintain their minimum armed speed until I try to take off, at which point they turn off. I checked mission planner for a potential error warning that there might be and none show. Regardless, I disabled the pre-flight safety checks. When the quad is plugged into mission planner, the quad motors arm and continue to spin at their minimum armed speed. I tried arming the quad plugged into mission planner and then unplugging, but the motors stopped spinning. Any help anyone can provide is greatly appreciated, thank you all for your time.

Please provide tlogs and/or dataflash logs to help troubleshoot your issue.

Thanks for the quick response TCIII.
Here is what I believe you are looking for:

[attachment=2]2016-02-24 20-46-45 1.bin[/attachment]

[attachment=1]2016-02-24 20-48-20 5.bin[/attachment]

[attachment=0]2016-02-24 20-51-32 17.bin[/attachment]

These are a few recent tests that I did
Only changes that were made was that the Log Files are now being created when I am disarmed as well and I disabled the compass. Both of these were done in Standard Parameters.
[attachment=4]2016-02-25 12-14-26 18.bin[/attachment]
[attachment=3]2016-02-25 12-14-34 19.bin[/attachment]
[attachment=2]2016-02-25 12-21-19 23.bin[/attachment]
[attachment=1]2016-02-25 12-21-43 24.bin[/attachment]
[attachment=0]2016-02-25 12-22-13 25.bin[/attachment]

See … -analysis/ for how to look at your logs

You have FS_BATT_ENABLED and FS_BATT_VOLTAGE set to 14V, but you have a reading on ~10.7V on your battery.

I’d suggest going through all the setup steps. Do not enable any failsafes at first, for battery and signal loss, you only want to test you can take off. When you can then look at enabling Failsafes that make sense.

Hope that helps :slight_smile:

[quote=“ihall21”]These are a few recent tests that I did
Only changes that were made was that the Log Files are now being created when I am disarmed as well and I disabled the compass. Both of these were done in Standard Parameters.
[attachment=4]2016-02-25 12-14-26 18.bin[/attachment]

Your 18.bin shows some very strange things happening with your motor outputs, and only loosely correlated to your throttle.

The outputs I’m seeing there - if your props weren’t spinning, they really should have been. Could I suggest the ESC calibration again?


I am sending the 5 most recent Bin Files

I attempted turning off the fail-safes as billbonney recommended. The motors did not immediately disarm after I armed them, but the throttle still acted weird. Hard to explain but here goes: no matter what setting the throttle lever was at (besides zero), the motors slowly spun up in speed until they peaked, but with no liftoff.

I did the ESC calibration recommended on, and during the calibration, spun up the motors. At a certain speed, the copter pitched backwards towards me slightly (I left the blades on), which was odd that equal power did not seem to be distributed.

After the ESC calibration the motors did the same slow acceleration as mentioned above.

[attachment=4]2016-02-26 22-31-52 28.bin[/attachment]
[attachment=3]2016-02-26 22-33-50 29.bin[/attachment]
[attachment=2]2016-02-26 22-34-11 30.bin[/attachment]
[attachment=1]2016-02-26 22-35-44 31.bin[/attachment]
[attachment=0]2016-02-26 22-36-11 32.bin[/attachment]


If you did the esc calibration with the props on you were unable to make sure you have full throttle access after you completed the calibration.
You need to establish that each step is right.

I would suggest redoing the calibration without the props on. After the calibration you should be able to move the throttle between minimum and maximum throttle and hear that your motors are responding correctly.

For whatever reason the all-at-once calibration would not work so I resorted to doing them manually. During the calibration I was able to get each motor to reach its maximum speed with immediate and correct response from the throttle stick. After the calibrations I connected the ESCs back into the APM and armed the quad. When I increased the throttle, the motors did the same eerie slow acceleration to max speed regardless of what the throttle stick was set at. I really do not understand why this slow speed up process is occurring. Thank you all for your continued help.

These are the most recent five and likely some are calibration tests
[attachment=4]2016-02-27 17-32-09 39.bin[/attachment]
[attachment=3]2016-02-27 17-32-24 40.bin[/attachment]
[attachment=2]2016-02-27 17-35-14 41.bin[/attachment]
[attachment=1]2016-02-27 17-35-42 42.bin[/attachment]
[attachment=0]2016-02-27 17-38-11 43.bin[/attachment]

Exactly what ESC are you using?

Sounds like they have “Helicopter mode” activated.

This is a mode which limits the delta v of the motors. In other words you (simplified) tell the ESC that "Ok, I want a X second long ramp up/ramp down time to/from max throttle.

This is useful in “normal” helicopters to limit the torque stress due to the intertia of the main rotor/transmission.

In calibration mode they will respond instantly as you typically perform this with the motor disconnected from the transmission, and because it is useful to provide instant feedback to the person performing the calibration.

Check your ESC manual if this may be the case. Some ESC’s are programmable via external hardware, some are programmable wia stick input.

Hello, I have been away for awhile. I am using SimonK 30A Autoshock ESCs.

Same problem with my quad, it already flew but after making some change to CHx_OPTION it arms, don’t respond to throttle and disarm after 3 or 4 seconds.

No failsafe enabled, checked rc3in response according to stick.

Made a reinstall of copter 3.3.3 without any success, don’t know what I’ve missed.

Here’s the log :
1 21-05-2016 17-08-44.bin (221.1 KB)
FC is a AUAV-X2 with E600 kit powered by 6S/4000 LiPo

Hello, ihall21 did you fix the issue with the throttle ramping up after introducing throttle? I have the same issue and nobody seems to have posted a fix.
Best wishes


Found my problem, the Motor Interlock don’t work as expected, can’t arm if it’s disabled (good thing) but arming state can’t be maintained when it’s enabled.

I replaced Interlock by emergency stop for now.

@pmusto , no I have not figured out the issue yet unfortunately. @furynick, I apologize but I do not really understand your posts.

If you don’t understand it’s probably because you haven’t the same problem I had.
Did you activate Motor Interlock on auxiliary channel ?