Servers by jDrones

Motors C & D on X frame spin faster than A & B causing flip on throttle up

I’ve got a new pixhawk cube setup. Everything checks out. Motors/props are correct layout and rotation. The HUD responds properly. The problem is as soon as I give it any throttle it flips over into its right side. It does this in both stabilize and acro mode. I tried removing the props and throttling up, and the left motors (C and D) spin up about 30% faster. All the motors spin the same speed in motor test mode. When I swap the ESC outs on the FC, C and D still spin faster. I’ve calibrated the ESC many times now. I’m stumped! Any ideas?

All the components are new
Cube 2.1
Hobbywing 50a
Kde 4215 460kv
APC 18x5
22000 6s

Can you provide the .bin flight log of one of the flips? It will help to know what the flight controller is trying to do.

And just to be sure, make certain that your motor outputs are in this order:

Note that this order is different than the ABCD order that Mission Planner uses in its motor test.

If you are 100% certain the motors are spinning in the correct directions, the props are on right, and that the flight controller is properly oriented, try reversing the affected channel in the radio…

In other words, if the aircraft is flipping in pitch, reverse Elevator. If it is flipping in roll, reverse Aileron. And then recalibrate the radio…

I had this exact issue when I replaced the gimbals in my Taranis X9E…

Oh, one other thing… Throttle testing with out props is useless. When you run Motor Test in Mission Planner > Initial Setup > Optional Hardware, the FC is not trying to get the aircraft level and the motors run at what ever throttle % you specif. When you arm the motors using the radio and take throttle above idle the PID controllers kick in and things get weird…

I experience the similar issue with my hexa. In my case Motor 6 ,Motor 2 and Motor 5 spins faster and try to flip to right side. Have you figured out any workaround for this. I also tried to do the ESC calibration by the Mission planer and manually and individually by connecting the ESCs one by one to LiPo and RX. but no use. what i have noticed was the it tries to flip asap i arm it and give even 1 mm of throttle but in the ESC calibration motors don’t spin u till i give more the 25% of throttle.
im thinking of re flashing the FC…

It is obvious you have something setup wrong, and I think it is the motor order. The clue is if the motor order was correct, motor 5 (front right corner) would not be spinning faster. In fact, motor #6 (front LEFT corner) would be spinning faster.

First, recalibrate the ESCs using Mission Planner and then leave them alone.

Then do this:

  1. Connect the Pixhawk to Mission Planner
  2. Take the props OFF.
  3. Plug in the battery.
  4. Press and hold the Arming Safety Switch until it stays illuminated.
  5. In Mission Planner navigate to Initial Setup > Optional Hardware > Motor Test
  6. Set Throttle % to 10
  7. Set Duration to 5
  8. Test each motor in sequence A, B, C, etc. The motor on the front right corner is A, Right Center is B, Right lower corner is C and so on. NOTE: This testing layout does not match motor order, 1,2,3… etc. Also, make sure the motors are spinning in the proper directions, with 1, 3 and 6 spinning Clock Wise, and 2, 4, and 5 spinning Counter Clock Wise.

Put the props back and verify that each one in on with the leading edge facing the direction of motor spin, and make a test flight. If the aircraft still tries to flip, go into your RC Transmitter and try reversing the ROLL channel.

If the aircraft still flips, verify that you have the flight controller orientation correct with the arrow pointing FORWARD.

Hii bro…
thank you so much and really appreciate for taking time to help…have tried all that workaround. Calibrated ECSs by mission planer as well as manually. Tried the motor test and the motor sequence motors are all fixed as mentioned in the ardupilot documentation just like this download the orientation seems to be ok and directions all seems ok…only thing whats left is to re flash the FC. I’ll do it tonight and see. ill update you guys on the progress…

Regards
Sanks

Servers by jDrones