Motor testing failure; Command was denied by autopilot

Hello,

I am trying to debug my quadcopter. I am using a brand new Cube Orange flight controller. It is connected by USB to a laptop. The controller is not connected to a battery, GPS, or safety switch, and I have disabled all of the arming checks. I have updated to the most recent 4.2.3 firmware for copters (quadcopter configuration).

I am trying to test the motors using Mission Planner. I would like to adjust the Motor 1 throttle in Mission Planner’s “Motor test” and see the corresponding change in the PWM signal in an oscilloscope. However, I receive the error “Command was denied by autopilot” for any test I try (ex: 20% for 10 seconds).

I can see 3.3 V pulses from MAIN 1 output of the CubeOrange, but they obviously don’t change. They are at a higher frequency and amplitude than the 5 V pulses I see from a servo tester. I wasn’t expecting that.

Am I forgetting any configuration step? I am new with quadcopters and Ardupilot and would appreciate any advice.

Did you disable the Safety Switch? Not connecting it doesn’t do that :slight_smile:

1 Like

Complementing @dkemxr response, if I am not mistaken, the FC will deny this command if you are sending it by USB (it is a safety concern about someone being close enough to a propelled motor and being injured during the test). Always perform it via telemetry radio.

Set these parameters and you should be OK

BRD_SAFETYENABLE,0
MOT_SAFE_DISARM,0

You can run it via USB, no issue with that.

1 Like

This worked! Thank you.

1 Like

I can confirm that I ran it with a USB once I followed @xfacta advice.

1 Like