Servers by jDrones

Motor test spinning one motor everytime


(Bob Smith) #1

Mission planner 1.3.5, APM: Copter V3.5.3, Pixhawk 2.4.8. Hexacopter configuration.

This is a similar problem to one discussed over a year ago but I see no resolution in that post Two motors spin at the same time when motortest

Here is my issue:
This is a brand new build. I have everything connected and just wired up the motors. I did ESC calibration all together and can ARM the machine and all the motors spin and respond to throttle.
When I attempt Motor Test I get the followtng:

  1. When throttle at default 5% only motor 2 (PX output channel 1) spins independent of which motor I select to test.
  2. When I up the throttle to 10% each motor responds as it should except motor 2 spins along with each. So Test Motor 1 gets 1 & 2 spinning the same speed and the same duration.
    Test Motor 3 gets 2 & 3 spinning
    Test Motor 2 gets just 2 spinning.
  3. I swapped the output channels of PX 1 and 3 to see if the fault was in the ESC or the wiring to the motor. The result is now that the new motor connected to PX output 1 is the offending motor. I conclude the error is the output from Pixhawk.

I have removed the 5v power to the rails and the zener connected across them to make sure and nothing else is connected to the back of the PX other than RC in.

Any suggestions of how to debug this further? I am not inclined to try to fly with one motor behaving badly.


(iseries) #2

Just did a motor test and all worked as expected.

I would check that the proper model is loaded on the flight controller.

Also what flight controller are you using. It would seem that the firmware is programmed to power both motors for some reason.

Mike


(Bob Smith) #3

. The details are in the post. I think I got the right model loaded initially. Everything looks as it should for the setup until this point.
To be clear, the motor 2 runs in parallel with every other motor I test. When any motor spins, it spins as well.
I guess I could start again and load plane and load the model from scratch. It couldn’t hurt and I can’t think of anything else to do.
Thanks for the reply


(mike kelly) #4

Also maybe load quad and see if the problem moves or stays on the same motor output, since the motor order is different in hex and quad.

good luck


(Jagger) #5

Have you checked your servo channels for anomalies ? You should have 6 consecutive numbers for the motors.(could be the scroll wheel in full parameters).

With a cheapy 2.4.8 I’d be tempted to open it up and look for solder bridges or wire tails on the outputs as well.I like those FCs ,and have three in copters,but I know quality varies considerably.


(Bob Smith) #6

SOLVED: The problem appears to have been an idiot with a keyboard - me.
Somehow, as Jagger suggested, I got my SERVOs in a bunch and had SERVO1 assigned to landing gear - which doesn’t seem quite right.
I had
SERVO1_FUNCTION,29 Landing gear !!!
SERVO2_FUNCTION,34 Motor2
SERVO3_FUNCTION,35 Motor3
SERVO4_FUNCTION,36 Motor4
SERVO5_FUNCTION,37 Motor5
SERVO6_FUNCTION,38 Motor6

I obviously changed this to 33 and we’re in good shape.
Thanks for all your responses


(Jagger) #7

Excellent.An easy one. :grinning:

An easy one to do too.My touchpad has caused plenty of grief.I’ve never been able to control it.


(Bob Smith) #8

My laptop has a touch screen and when I’m working on something I often scroll with a finger. I have changed values of parameters like this but usually caught them up to now. That’s my official excuse.
Hope to get her in the air this week. Thanks again for the nudge.