Motor test fails to spin correct motors

This may be solved today due Mission Planner update but because I can’t be sure I report it here.

  • Hexacopter 3.5.3 crashed after 2 secs of hover by leaning strongly right from 1 meter from ground (maiden flight)
  • I made triple check for motor connections and rotations and they were correct. All calibrations were done like manymany times before (PC 1 win10)
  • I made “Motor test” by using mission planner downloaded about a week ago ( didn’t mark version down PC 1 win10). Motor Test spun motors in this order: A=1, B=3, C=none, D=4, E=2, F=6, G=none and H=5. As you notice these are not correct.
  • Next attempt was to upload 3.2.1 with MP 1.3.35 and motor test was fine (PC 2 win7)
  • Next I updated Mission planner to 1.3.50 half an hour ago before writing this report and made Motor Test. Motor Test was fine (PC 1 win10).

Conclusion: Either 1) 3.5.3 on Hexarotor has something wrong with motor control and it caused crash and motor test failure or 2) Mission Planner I used before (downloaded latest about a week ago) had a bug on Motor Test which is now repaired on update today and firmware has nothing wrong.

In full parameters on 3.5.3 check that you have FRAME_CLASS - set to 2 (HEXA) and FRAME_TYPE -set to 1 ( X config).That should give you the clockwise motor test pattern.Frame type is a new addition that needs to be manually selected after firmware install.I’ve got a couple of hexas flying on 3.5.2 and 3.5.3 didn’t have any pertinent changes in it.

Any help ?


Thanks! I try this.
After posting original message I uploaded 3.5.3 again and Motor Test changed to be like described above. Perhaps I have wrong frame type selected then.

It has caught a few people out which is why I mentioned it.Hope it works.

This worked. I had Octa (3) selected and changed it to 2. This is very confusing and risk feature because it is so hidden. Most likely reason for my crash. Lesson learned. If motor test fails, Do Not Fly.

Now Mission Planner had that selection graphically too, or at least buttons are there. Strange I didn’t notice it last week with earlier version.

Excellent that’s resolved.

The code is getting more complex and hard to keep up with.But someone has to crash and burn to test it out. :grin:

I try to read a lot here and pick up these little problems before I crash too badly.

Being on first line of development is risky but it’s own choice :slight_smile:
In fact this copter is going to receive some abuse anyway. I plan to make simulated motor failure tests and see how Arducopter works. I have a parachute aboard connected to Pixhawk for automatic eject and it is also connected directly to receiver for manual eject, just in case. We have one failure video published where SuperX didn’t survive from hexacopter one motor failure. So it is not sure that Hexa helps and it is always dependent of algorithms. Does autopilot recognize one or more motor failure and can it control situation. Never know without trying :slight_smile:

Arducopter will fly it with a motor loss if you have enough overhead power.Sometimes.It can depend on how the motor fails and how much vibration it produces.It will naturally yaw but it’s that power you need.Always, of course.

I want a parachute or three.

PM me and I can help with parachutes. I don’t want to spam here.