Motor test doesn't work

I have setup most of the electronics on my drone. I am using a 2s 150mah battery for the control board and the camera, and a 1000mah 4s for the motors. All grounds are connected when testing with a continuity tester. So I go to test my motors on the mission planner with usb power and my 4s battery plugged in, and no motors are turning. Anyone know how I can fix this issue?

Thanks in advance.

Have you done a radio calibration? Try that the do a motor test.

I did a radio calibration but that didn’t change anything. The radio was already calibrated I don’t understand why that would make a difference anyway in the motor test page. I didn’t calibrate the gyro or accelerometer yet though.

Hello, I did an accelerometer calibration and level calibration and it didn’t change anything. I will give you more info on my setup: I am using omnibus F4 V6 nano and I have all 4 pwm outputs on 4 individial ESCs. Attached is a picture of what motor I connected to what pad. This should usually be trivial and just work but they are not turning. Please any help would be appreciated. thanks.

By the way I should note that I am getting the initial motor sound when I plug the batttery.

What percentage are you doing the motor test at and is the safety switch armed?

I tried 5% up to 30% and nothing worked. I don’t have a safety switch.

When I go to test the motors, the control board goes to the state “DISARMED FAILSAFE”

Is there any mention of what the failsafe is? Does the autopilot allow you to arm normally?

You need to either disable the board safety switch, or add safety switch for the motor tests to run.

Hey So I didn’t find BRD_SAFETYENABLE on my list, which is the first thing I found on google “disable the board safety switch”. I did find BRD_SAFETYOPTION and set that to 0. Motots are still not turning. Attached is my params.param.param (19.6 KB)

So you have a Flight Controller that doesn’t have a Safety Switch option. There are many of those. I don’t see anything in the parameter file preventing Motor Test from running so I would suppose you have a wiring or power problem.

I should mention that I didnèt plug a GPS to the control board yet. Also I’m not sure if the propper ESC is selected, maybe there are other ESC settings that are done by default. I connected the 4 outputs of the board to the 4 different ESCs. Let me know if there is a parameter that sets the ESC type.

I can confirm that the motors are still not turning after I added a GPS module and it recognized my location. I will test the PWM outputs of the board with an oscilloscope soon.

You don’t need a GPS module for Motor Test to Function. What Flight Controller and ESC do you have and how are they connected?

Not sure the ESC type because there was no label when I baught from someone. The controller I baught from banggood, and is the omnibus f4 v6 nano. I posted a picture of where I connected the ESC wires. When I plug the ESC, I hear the motor start sound, and then I hear the motor ready sound. The motor test page on missionplanner does not turn the motors nor do they turn when I arm the drone and up the throttle.

My next step is to connect a rc receiver to each ESC to make sure they work, and if they work I will see the PWM output of the omnibus on a osiloscope.

individual motor test with receiver did not work. I have some work to do with my wiring .-.

I originally bought this drone with a different FC on it, and it had betaflight. I replaced the FC with an omnibus nano, and I figured out why the motors are not turning.

The ESC are using the multishot protocol, I confirmed this when I plugged the old FC to betaflight and it says the ESC are multishot. I didn’t know this before because there are no tags on the ESC. Anyone know if ardupilot supports this type of ESC? According to my research it doesn’t but if someone can confirm that would be nice. Thanks.

It doesn’t work that way. ESC’s are configured on start to accept whatever protocol is being provided to them from the Flight controller. The protocol is not hard coded or configured. Feed it PWM, they are in PWM mode, feed it Dshot they are in Dshot mode (assuming they support the protocol). Etc.

@robustcode were you ever able to work this out?